WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Position order (8 posts)

  1. forallatlantis
    Member
    Posted 5 months ago #

    Hi there

    How can I change the position order of your plugin, for example before or after other plugin output?
    Is there any add_filter that I can call to make the order?
    I tried with related_posts() function, but it display twice. The second output display is in the correct place but I can't control the first one.

    Best regards

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 5 months ago #

    You would have to turn off the "Automatically display" option in the "Display options" panel, and add PHP code. See "How can I move the related posts display?" in the FAQ.

  3. circa78
    Member
    Posted 4 months ago #

    Hi, I also have a similar problem.
    I use Less WordPress theme.
    I've already turned off the "Automatically display" option. I've also added the '<?php related_posts(); ?>' where I want (below post meta, and above comments). It didn't display twice, but it changed some parts of comment section into link of the last title of the related posts.
    When I move the PHP somewhere else, i.e. above post meta or below comments, it works just fine.

    Thank you!

  4. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    Hi circa78, can you post a link with this issue so I can take a look?

    Thanks.

  5. circa78
    Member
    Posted 4 months ago #

    Sure, you can see it in this article for example: http://anom.web.id/lima-sekawan-edisi-jadul/

    Thank you

  6. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    You are missing a closing </a> at the end of each of the links in the "Related Posts" section. Are you adding the code manually?

  7. circa78
    Member
    Posted 4 months ago #

    Whoops... My bad.
    I falsely edited some of the code, when I tried to customise it, and forgot to put the right one back.
    I've removed all the bad blood, and installed a fresh one. After I did all that you've mentioned above, now the plugin works like a charm.
    Thank you.

  8. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    Great! Glad it's working for you.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.