WordPress.org

Ready to get started?Download WordPress

Forums

Fancier Author Box by ThematoSoup
Position of author box (tried tips,didn't work) (7 posts)

  1. Nerin
    Member
    Posted 10 months ago #

    Hey Dragan,

    First off, thanks for a great plugin. I bought Fanciest Author Box but then found this and felt the less tabs suited our theme better. Both are fantastic plugins though.

    My issue is with positioning of the box.
    I've tried the usual method of add_filter( 'the_content', 'ts_fab_add_author_box', random number ); but it isn't working for me.

    As you can see here: http://www.krank.ie/category/society/tom-cruise-the-irish-scientology-protests/ If I want to break my posts up into multiple pages the page numbers appear below the author box.

    I just want to move it below the page numbers so as readers don't miss them. Any idea why the usual method isn't working?

    Regards,

    N

    http://wordpress.org/extend/plugins/fancier-author-box/

  2. Dragan Nikolic
    Member
    Plugin Author

    Posted 10 months ago #

    Have you tried it with Fanciest Author Box and then changing the "Execution priority" in Display Settings? I just want to make sure that it doesn't work on your website.

  3. Nerin
    Member
    Posted 10 months ago #

    I can move it above or below the "share this" buttons, but no further. I've also disabled the buttons in case they were causing a problem.

    I'm just trying to get it to sit where the red line is http://imgur.com/HiQKuvt

  4. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Nerin,

    Unfortunately, it's not possible to get it to show below pagination links. The plugin is added by being appended or prepend to the_content function that displays post content. The pagination links are added by another function, so it's impossible to have the author box below them.

  5. Ellorye
    Member
    Posted 8 months ago #

    I am having the same issue and I saw you made it... care to share the solution?

  6. ilovecola
    Member
    Posted 7 months ago #

    I had the same problem, but I found solution!

    This is how I did:

    1. Go to: /wp-content/plugins/fancier-author-box
    2. Modify line 143 in file ts-fab.php:

    `add_filter( 'the_content', 'ts_fab_add_author_box');

    by adding ",0" (without quotes) right after 'ts_fab_add_author_box'

    3. Result should look like this: add_filter( 'the_content', 'ts_fab_add_author_box', 0 );

    This modification gives highest priority to author box and it will be loaded first! :)

  7. Slobodan Manic
    Member
    Plugin Author

    Posted 7 months ago #

    ilovecola,

    Thanks for posting this. However, even with highest priority assigned to ts_fab_author_box function that will only make sure it is the closest one to content of all the other functions attached to the_content hook. If paginate links are added by using a separate function and not the_content filter, this solution won't help.

Reply

You must log in to post.

About this Plugin

About this Topic