WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] Position flags in wp multisite header (9 posts)

  1. johnnyRing
    Member
    Posted 1 year ago #

    Hi,
    I fear I'm not able to position the flags language in the header. I'd like them to appear in right side.

    I've inserted if (function_exists ('the_msls')) the_msls () in the header, then I've tried to insert html code like explained here but nothing.

    I've tried to add:
    .the_msls_language_box {
    position: absolute;
    top: -70px;
    left: 940px;
    }
    in css file: nothing

    Then I've added
    img[src="http://b5srl.eu/wp-content/plugins/multisite-language-switcher/flags/gb.png"] {position: relative;top: -37px;left: 651px;}
    img[src="http://b5srl.eu/wp-content/plugins/multisite-language-switcher/flags/fr.png"] {position: relative;top: -37px;left: 655px;}

    always in css file and the position is good, but only for native language.
    that is, for en.mysite.eu and fr.mysite.eu nothing changed.

    Can you help me, please?
    thanks a lot
    j.

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not a Web Designer but here is a good example: http://www.freely.de/

    Put this in the header.php

    <div id="language">
    <?php if ( function_exists( 'the_msls' ) ) the_msls(); ?>
    </div>

    and this in the style.css of your template

    #language { position:absolute; top:34px; right:7px; }
    #language a { margin-left:5px; }

    to have a similar output.

  3. johnnyRing
    Member
    Posted 1 year ago #

    Thanks really a lot!
    Unfortunately it works only for native language site, not for the others.
    It's weird but it goes in this way :-(

  4. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Do you made the setup in all of your sites? If yes, do you use different themes for your sites?

  5. johnnyRing
    Member
    Posted 1 year ago #

    Sorry, all works fine :-), I had some cookies in the cache!

    Seldom I've meet a person so kind. Thanks again for your very useful plugin and your amenability!

  6. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Very good. Thanks!

    Don't forget to rate the plugin. ;-)

  7. johnnyRing
    Member
    Posted 1 year ago #

    Just done! ;-)

  8. Goodvalley
    Member
    Posted 1 year ago #

    Sorry, resolved just after the question.

  9. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    OK, very good!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.