WordPress.org

Ready to get started?Download WordPress

Forums

Portfolio Press
Portfolio Press theme, cannot center navigation (13 posts)

  1. C_barnes
    Member
    Posted 1 year ago #

    Portfolio Press theme, cannot center navigation

    Help!

    I can't figure out how to center my navigation and my logo- is there a way to do it so that it the elements are still evenly spaced when viewing on a mobile or ipad (the things I've tried look bad when I view on a smaller screen)? Thanks!

    http://www.carlabarnesdesign.com/

    **I've gotten a reply:

    @C_barnes, I check your website already, those are css problem.
    [Moderated - see below post re: this theme]

    problem is you used fixed width instead of %. I think the whole structure is used with % and only logo and header are fix width(px) and logo is actually working correctly if you change the margin left value to % instead of px. and also navigation li are too large to show and they are hidden underneath the header wrapper.

    Hope this might give you a hint.**

    ^I don't understand how to code for this... would I add something like this to my child theme:

    #logo {
    width: auto;
    margin: 0px auto;
    }

    #navigation {
    z-index: 200;
    }

    Is my logo too big?

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    I don't understand, your navigation looks centred to me. Is it just not on a particular browser?

  3. C_barnes
    Member
    Posted 1 year ago #

    I've just checked- it works on Safari... but not on Firefox or Chrome...??

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Is this what you see on Chrome [screenshot]? If so, can you explain further on how you want it centred?

  5. C_barnes
    Member
    Posted 1 year ago #

    Nope,

    This is what I've got: http://www.carlabarnesdesign.com/303/

    For me, it looks like this on FF and Chrome... I've just added the border to the nav so I seem to be seeing the latest version which isn's showing up on Safari...

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    Have you cleared your FF and Chrome browser caches?

  7. C_barnes
    Member
    Posted 1 year ago #

    I cleared them and it looked like what you've been seeing until I clicked "update file" on my child theme and then it was back to what I've been seeing... I'm sorry, I'm new to coding...

  8. Andrew
    Forum Moderator
    Posted 1 year ago #

    Which versions of Chrome and FF are you seeing the issue in?

  9. C_barnes
    Member
    Posted 1 year ago #

    Chrome: Version 25.0.1364.160
    FIrefox: 19.0.2

  10. Andrew
    Forum Moderator
    Posted 1 year ago #

    Can you try viewing your website on another device?

  11. C_barnes
    Member
    Posted 1 year ago #

    It looks the same in Chrome on my laptop, in FF however it looks correctly centered... Is there some sort of issue with Chrome? It doesn't really make sense to me because even if it's centered I would think that you should still be able to see the underlined border...

    My child theme is simple and short- maybe there is an error??? Thank you so much for taking the time to help me :)

    /*
    Theme Name: ppchild
    Theme URI: http://wptheming.com/portfolio-theme/
    Description: Child Theme for Portfolio Press
    Author: Carla
    Author URI: http://wptheming.com/
    Template: portfolio-press
    Version: 0.1
    */

    @import url("../portfolio-press/style.css");

    #header {
    border-bottom-style:double;
    border-color:#6D6E70;
    }

    #navigation {
    text-transform: uppercase;
    text-align: right;
    border-bottom-style:double;
    border-top-style:double;
    border-color:#6D6E70;
    }

    #navigation ul a{
    color: #6D6E70;
    }

    #logo {
    width: 252px;
    margin: 0px 264px;
    }

    #content h1 {
    display:none;
    }

  12. Andrew
    Forum Moderator
    Posted 1 year ago #

    There is no such element with an id of "header", so I don't see why that should be working.

  13. C_barnes
    Member
    Posted 1 year ago #

    Haha, it's not (i'm going to delete it), but the border on the navigation element is... its just the for some reason the nav menu is not within the navigation...

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic