WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Port forward - Switches (9 posts)

  1. surge
    Member
    Posted 3 years ago #

    Hi There.

    I am having a some difficulty with one aspect.
    I have WordPress 3.1 installed and running fine on my
    xserver at work port:80. I can access it locally without issue.
    localhost/wordpres ....(no problems)

    I have successfully port forwarded to port:7777
    http://6x.2xx.1xx.1xx:7777/wordpress/
    I can access it from home for a bit, becuase after
    I connect the url changes to http://localhost/wordpress
    and causes it to point to the wrong direction.

    If I try with a drupal installation
    http://6x.2xx.1xx.1xx:7777/drupal/
    the url maintains its form and connects to all other
    pages as http://6x.2xx.1xx.1xx:7777/drupal/...whatever page

    Does anyone have any idea how to keep the url the same as the drupal example. So that when Im at work the company can see the wordpress site.

    And when at home can see the word press site.

    Im loving wordpress, and do not want to switch to drupal because of this one little thing.

    Anyone?

  2. arkgroup
    Member
    Posted 3 years ago #

    surge,

    Read this article:
    http://codex.wordpress.org/Changing_The_Site_URL

    I suggest you phpMyAdmin method.

  3. surge
    Member
    Posted 3 years ago #

    Thanks very much.

    I quickly read the article.
    From what I understand it looks like the method will only Keep the port forwarding up until the admin screen.

    I will try to read and understand more.

    But Im looking for the entire site to be redirected from whatever location is calling on the site.

  4. surge
    Member
    Posted 3 years ago #

    arkgroup,

    After racking my brain, and to put it

      more straight forward

    I think I want "Relative" and not "Absolute" url adressing.

    so [url]/wordpress, can be whatever url the user typed in.

    Now I just have to find the right implementation of this or plugin.

    any other thoughts

  5. surge
    Member
    Posted 3 years ago #

    I Think I found my solution for anyone who reads this.
    I will know later once I change one piece of information on my firewall at work.

    My Problem seems to be with Port 80
    IM using Mamp

      First I log into admin on wordpress:

    I change WordPress address (Url) to http://(your_ip):8888/wordpress
    I change Site address (Url) to http://(your_ip):8888/wordpress
    I save changes and get an error because I am now pointing to a
    different port.

    I change my port on mamp to apache 8888 mysql 8889 (its default)
    Set Firewall (outside ip):port 8888 >Forward to (inside ip):port8888
    I now goto http://(your_ip):8888/wordpress - and Bingo!

    I now see the url bar say exactly what I want.

    so since I am at home right now with no access to my firewall I am going to have to wait and see on monday if the new port I put wordpress on works remotley.

  6. surge
    Member
    Posted 3 years ago #

    Still only sort of works.

    Changed Fire wall settings and it only ever seems to work one way.

    So working from home > wordpress address and site url to
    http://(external_ip):8888/wordpress - this works from home, but not from the office

    At the office > wordpress address and site url to
    http://(internal_ip):8888/wordpress - this works from office, but not from home.

    Im using logmein to see this affect.

    Home Computer > Fire wall External ip > forwards to > Internal ip

    Its just not working both ways. hmmm..ANy one else reading this or can help here?

    Is this just all firewall related?

  7. fonglh
    Member
    Posted 3 years ago #

    See if your firewall or router has a setting which blocks loopback connections.

    http://www.dyndns.com/support/kb/loopback_connections.html

  8. surge
    Member
    Posted 3 years ago #

    Thanks for the info - Will look into it right away.

  9. surge
    Member
    Posted 3 years ago #

    O.k Everything works now.

    I can now access my wordpress site from home and from work.

    This makes life so much easier now.

    The real trick was the proper port forwarding allowing loop backs.

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic