WordPress.org

Ready to get started?Download WordPress

Forums

SendPress Newsletters
Port 587 seems to be blocked. (6 posts)

  1. alexbeech
    Member
    Posted 4 months ago #

    Send press won't send I get the message
    Port 587 seems to be blocked.

    Any help please?
    Alex

    https://wordpress.org/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    If you are trying to send with Gmail, you could try port 465. Otherwise, you'll need to contact your web host to open the port or send through your website. Sendpress pro has options for sending through third parties that use their API and do not require email sending ports to be open. These often have better deliverability than either sending thriugh your website or through Gmail.

  3. js7492
    Member
    Posted 4 months ago #

    hey guys did you figure out this issue? I am having problem sending emails i can send test emails but not regular email. plus my ports are blocked and notsure how to open them up. any advice would be appreciated

  4. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    I just updated your other ticket. You probably need to contact your hosting company. With our Pro version we support API sending which resolves the port blocking issue.

    Doug

  5. alexbeech
    Member
    Posted 4 months ago #

    I contacted my hosting company and they said it had been blocked because I exceeds their send limit which was 500 per 24h. The port was blocked for 1 week and then automatically reopened, but they suggested I add and SPF record to my DNS entry to prevent it from happening again.
    Sorry I can't be more help.

  6. itdoug
    Member
    Plugin Author

    Posted 4 months ago #

    SPF records won't help with exceeding your rate of 500 per day. This should explain SPF better

    https://sendpress.com/blog/273/use-spf-to-avoid-an-email-newsletter-spam-sunburn/

    Sounds like you need to set your daily sending limit under Settings > sending. If you make it 499 sendpress will stop sending until the next day.

Reply

You must log in to post.

About this Plugin

About this Topic