WordPress.org

Ready to get started?Download WordPress

Forums

WordPress PopUp
[resolved] Popup plugin not working with W3 Total Cache (10 posts)

  1. aramaz
    Member
    Posted 6 months ago #

    This plugin is not working well with W3 Total Cache. I configure it so it doesn't appear more than one time, but apparently it keeps on displaying in the cached version of the page because nothing seems to make it go away, not even clicking on the bottom message "Never display this again".

    I've tried blocking its cookie and directory in the W3 configuration and nothing seems to work. I had to turn off caching just to go forward with the popup campaign.

    Has anyone managed to get these two plugins working?

    https://wordpress.org/plugins/wordpress-popup/

  2. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @aramaz,

    That I can find, there have been reported issues using the plugin with W3 Total Cache, but apparently others have had it working with WP Super Cache.

    I'm not aware of any way to get it working with W3, myself. I'll ask some of the team here if they're aware of anything though.

    Cheers,
    David

  3. aramaz
    Member
    Posted 6 months ago #

    Thanks David. Did you hear anything from the team?

    I'll change caching plugins if I have to, but if I remember correctly I had trouble with Wp Super Cache on a previous site which is why I stopped using it altogether and started using W3.

  4. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @aramaz,

    Unfortunately I've not heard any positive word with this one. Any plugin-based caching working alongside the popover sort of undermines what the popover's doing.

    I've merely "heard" that WP Super Cache may be able to work with the popover but really, either of these caching methods would present difficulties with a pop up plugin like this.

    Cheers,
    David

  5. aramaz
    Member
    Posted 6 months ago #

    That's unfortunate, since I have to turn off frontpage caching making my site slower. Do you have any recommendations?

  6. WPMU DEV
    Member
    Posted 6 months ago #

    Hi @aramaz,

    Try using "External Load" or "Custom Load" Pop Over loading method from Pop Over Settings page on the following path.

    Admin -> Pop Overs -> Settings

    After making these changes clear the cache from the cache plugin to reflect these changes.

    Kind Regards,

  7. aramaz
    Member
    Posted 6 months ago #

    This seems to have worked, thanks!

  8. WPMU DEV
    Member
    Posted 5 months ago #

    Hi @aramaz,

    That's great news! Glad it's working for you now :)

    You are most welcome, if I can be of any further assistance please don't hesitate to ask :)

    Cheers,

  9. candaceljoseph
    Member
    Posted 5 months ago #

    I'm using W3 Total Cache as well and have tried every loading method available, clearing the cache each time. I can't get the pop over to display and only have 2 rules applied. Help!

  10. WPMU DEV
    Member
    Posted 5 months ago #

    Hi @candaceljoseph,

    Sorry to hear of the problems you are having.

    Could you please share me your site link to troubleshoot it?

    Also please tell me which two rules you are using.

    Kind Regards,

Reply

You must log in to post.

About this Plugin

About this Topic