WordPress.org

Ready to get started?Download WordPress

Forums

WordPress PopUp
[resolved] PopUp not working in my site (38 posts)

  1. majofa
    Member
    Posted 1 year ago #

    I have installed the WordPress PopUp plugin, but it is not working in my site, http://fedefutbolcr.com

    I have only one rule: show the popover if the user is not logged in to your site.

    Thanks

    http://wordpress.org/extend/plugins/wordpress-popup/

  2. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @majofa

    It sounds like the settings have not been applied correctly.

    What are the sizes and positions set to? Can you attach a screenshot showing these settings?

    Cheers,
    Mike

  3. raisincanearts22
    Member
    Posted 1 year ago #

    yeah. I am having the same issue. I actually deactivated wp-membership because I saw where it changed my role from "administrator" to "membership administrator". Once that was done I tried popup again but still getting "You do not have sufficient permissions to access this page."

  4. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @raisincanearts22

    Sorry can you re-explain that? When you enable PopUp, does the entire website say you don't have permissions when you access the front end? Or is this in the admin area?

    What if you manually navigate back to /wp-admin, does it load as normal?

  5. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 1 year ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  6. Christian K. Nordtomme
    Member
    Posted 1 year ago #

    Hi,

    I think I may have the same problem on my site, skriftlig.no. (There's supposed to be a popup on this post http://www.skriftlig.no/753/om-a-distribuere-pressemeldinger/)

    I installed the plugin, and created a popup, but the popup didn't/doesn't show even if all the rule(s) are true. (My rule now is "on a certain URL, but i have also tried others, alone and in combination. And I've tried different popups.) I don't get any error message, the popup just doesn't show – in "normal" browsing nor in incognito windows.

    • I tried disabling all other plugins, and removing an AddThis script I had installed.
    • I tried deleting the MailChimp form/script I had in the popup.
    • I tried deleting and reinstalling the popup plugin, but when I reinstalled, the popup I had created was still there, so obviously not everything was deleted.
    • Originally I had my WP installed in a subfolder, but I moved it back to the root (I was going to do that anyway).

    No dice.

    When I go to settings and try to change "Pop Up loaded using", the entire page changes to say that I don't have permissions to access that page, and the URL is only http://www.skriftlig.no/wp-admin/admin.php?page=

    When I try to activate the Add-on Test Head Footer, the page reloads, but the Add-on is still inactive.

    Having looked at so many different popup/popover plugins, this is the only one that seems to be any for what I need, so I would really appreciate it if you could help me figure out what's wrong, and I could help you. :-)

  7. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 11 months ago #

    Hi guys,

    we have just released new version of the plugin 4.4.5.4 where the issue should be resolved.

  8. majofa
    Member
    Posted 11 months ago #

    Hi
    I have updated to the last version 4.4.5.4 and still can´t get the popup to show.
    No rules.

    When I apply the addon Test Head Footer, I get the following message:
    Your active theme:
    Is missing the call to <?php wp_head(); ?> which should appear directly before </head>
    Is missing the call to <?php wp_footer(); ?> which should appear directly before </body>

    But the calls are present in header.php and footer.php

  9. jdev
    Member
    Posted 10 months ago #

    Im also having the same problem here: http://www.thechurchinfo.org/thechurchwelcome/

  10. Mike
    WPMU DEV Support Staff
    Posted 10 months ago #

    Have either of you tried loading in the footer? Or custom load?

    This is done from Settings > Media

  11. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 10 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    If you wish to try loading in the footer, or the custom load and still have issues then please let us know.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  12. Isaacx
    Member
    Posted 7 months ago #

    Hello,

    I have the same problem than Christian K. Nordtomme.

    I activated the Test Head Footer and I get :

    Has the call to <?php wp_footer(); ?> but it is not called directly before </body>

    I have tried the 3 pop loading options, none are working.

  13. David
    WPMU DEV Support Staff
    Posted 7 months ago #

    Hi @Isaacx,

    Thanks for posting, sorry you're experiencing some trouble with this. Let's see how we can sort this.

    Could you please check your theme's footer.php file to see if there's a wp_footer() call in there before the </body> tag?

    You could check on that through your admin area at Appearance > Editor, then select the footer.php file from the list on the right.

    If that function doesn't get called before the </body> tag, you might just be able to move it so that it does by cutting and pasting it.

    Cheers,
    David

  14. Isaacx
    Member
    Posted 7 months ago #

    Hi David and thank you for getting back to me !

    I'm not sure about the answer so here is what the footer.php contains :

    <?php
    /**
     * The template for displaying the footer.
     *
     * Contains footer content and the closing of the
     * #main and #page div elements.
     *
     * @package WordPress
     * @subpackage Illustrate
     * @since Illustrate 1.0
     */
    ?>
    
        </div><!-- #main-content --> <?php // main-content opens in header.php ?>
    
                <footer id="footer" class="site-footer">
    
                    <div id="footer-widgets" class="container row clr">
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col clr-margin">
                            <?php dynamic_sidebar('footer-one'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-two'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-three'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-four'); ?>
                        </div><!-- .footer-box -->
    
                    </div><!-- #footer-widgets -->
    
                    <div id="footer-bottom">
    
                        <div class="container row clr">
    
                            <div id="copyright" class="span_10 col clr-margin" role="contentinfo">
                                <?php if ( wpex_get_data('footer_text') !== '' ) {
                                        echo do_shortcode( wpex_get_data('footer_text') );
                                    } else { ?>
                                    <p><?php _e('Copyright','wpex'); ?> <?php echo date('Y'); ?> &middot; <a href="<?php echo home_url(); ?>" title="<?php bloginfo('name'); ?>"><?php bloginfo('name'); ?></a></p>
                                <?php } ?>
                            </div><!-- #copyright -->
    
                            <div id="footer-bottom-menu" class="span_14 col">
                               <?php wp_nav_menu( array(
    								'theme_location'	=> 'footer_menu',
    								'fallback_cb'		=> false,
    							) ); ?>
                            </div><!-- #footer-menu -->
    
                        </div><!-- .container -->
    
                    </div><!-- #footer-bottom -->
    
                </footer><!-- #footer -->
    
        </div><!-- #wrap -->
    
    <?php wp_footer(); ?>
    
        <div class="social-share">
            <div class="overflow">
            		<div>
            			<a class="a-like close">X</span></a>
            			<span class="top">-</span>
            			<a class="a-like end">Close forever</a>
            		</div>
    
            		<h2>Facebook</h2>
            		<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fgeekxprod&width=292&height=258&show_faces=true&colorscheme=light&stream=false&show_border=false&header=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:292px; height:186px;" allowTransparency="true"></iframe>
    
            		<h2>Twitter</h2>
                    <a class="twitter-timeline" href="https://twitter.com/Geekxprod" data-widget-id="310494187034378240">Tweets by @Geekxprod</a>
                    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
    
            		<h2>Tumblr</h2>
            		<iframe class="btn" frameborder="0" border="0" scrolling="no" allowtransparency="true" height="25" width="200" src="http://platform.tumblr.com/v1/follow_button.html?button_type=1&tumblelog=geek-x&color_scheme=light"></iframe>
            </div>
        </div>
    
    </div>
    
    </body>
    </html>

    Thank you very much for your help.

  15. Isaacx
    Member
    Posted 6 months ago #

    @David

    Are you still here ? :)

    Thank you

    EDIT : just found that there was a </body> but not a <body> how can that be possible ?

  16. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Isaacx,

    Yep, sorry for the delay, not sure how this feed got missed in my reader!

    Could I ask for you to try the following as a replacement for that and see how it works for you?

    <?php
    /**
     * The template for displaying the footer.
     *
     * Contains footer content and the closing of the
     * #main and #page div elements.
     *
     * @package WordPress
     * @subpackage Illustrate
     * @since Illustrate 1.0
     */
    ?>
    
        </div><!-- #main-content --> <?php // main-content opens in header.php ?>
    
                <footer id="footer" class="site-footer">
    
                    <div id="footer-widgets" class="container row clr">
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col clr-margin">
                            <?php dynamic_sidebar('footer-one'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-two'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-three'); ?>
                        </div><!-- .footer-box -->
    
                        <div class="footer-box <?php echo wpex_grid_class(wpex_get_data('footer_col','3')); ?> col">
                            <?php dynamic_sidebar('footer-four'); ?>
                        </div><!-- .footer-box -->
    
                    </div><!-- #footer-widgets -->
    
                    <div id="footer-bottom">
    
                        <div class="container row clr">
    
                            <div id="copyright" class="span_10 col clr-margin" role="contentinfo">
                                <?php if ( wpex_get_data('footer_text') !== '' ) {
                                        echo do_shortcode( wpex_get_data('footer_text') );
                                    } else { ?>
                                    <p><?php _e('Copyright','wpex'); ?> <?php echo date('Y'); ?> &middot; <a href="<?php echo home_url(); ?>" title="<?php bloginfo('name'); ?>"><?php bloginfo('name'); ?></a></p>
                                <?php } ?>
                            </div><!-- #copyright -->
    
                            <div id="footer-bottom-menu" class="span_14 col">
                               <?php wp_nav_menu( array(
    								'theme_location'	=> 'footer_menu',
    								'fallback_cb'		=> false,
    							) ); ?>
                            </div><!-- #footer-menu -->
    
                        </div><!-- .container -->
    
                    </div><!-- #footer-bottom -->
    
                </footer><!-- #footer -->
    
        </div><!-- #wrap -->
    
        <div class="social-share">
            <div class="overflow">
            		<div>
            			<a class="a-like close">X</span></a>
            			<span class="top">-</span>
            			<a class="a-like end">Close forever</a>
            		</div>
    
            		<h2>Facebook</h2>
            		<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fgeekxprod&width=292&height=258&show_faces=true&colorscheme=light&stream=false&show_border=false&header=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:292px; height:186px;" allowTransparency="true"></iframe>
    
            		<h2>Twitter</h2>
                    <a class="twitter-timeline" href="https://twitter.com/Geekxprod" data-widget-id="310494187034378240">Tweets by @Geekxprod</a>
                    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
    
            		<h2>Tumblr</h2>
            		<iframe class="btn" frameborder="0" border="0" scrolling="no" allowtransparency="true" height="25" width="200" src="http://platform.tumblr.com/v1/follow_button.html?button_type=1&tumblelog=geek-x&color_scheme=light"></iframe>
            </div>
        </div>
    
    </div>
    
    <?php wp_footer(); ?>
    </body>
    </html>

    It's just moving the wp_footer() call to the bottom of the page. Not sure that'd sort it but it'd definitely place the call after all that JavaScript already on the page.

  17. Isaacx
    Member
    Posted 6 months ago #

    @David

    Hello David and thank you for your help!
    I still have this message :

    Your active theme:
    Has the call to <?php wp_footer(); ?> but it is not called directly before </body>

    and no pop-up showing its face...

    Not sure what else I can do. I would really like to use this add-on because it's the only one that have the options i'm actually looking for

    Thank you!

  18. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Isaacx,

    That's odd, just to be sure we got this covered, could I ask how the popup works using a default theme, say Twenty Fourteen?

    If that doesn't work, then this is actually due to a plugin conflict, which I'm sure we could sort.

    Thanks,
    David

  19. Isaacx
    Member
    Posted 6 months ago #

    Hello David and thanks again for your help

    I have just tried to activate Twenty Fourteen theme and refresh the page again, but still no pop-up was displayed.

    I'm not sure how to proceed now..

    Thank you,

    Isaac

  20. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Isaacx,

    Hmm, I assumed you were experiencing the same issues as most others here due to a plugin or theme conflict of some sort, but I wonder if it's simpler?

    Could I ask, could you try something really simple in the popup content, like a simple "Hello" text? And then try using a simple rule, like the logged out rule?

    With that you should be able to see that popup when using a different browser, that's not logged in, for example.

    Could you let me know how that works for you?

    Or better yet, could you provide a link so we could have a look?

    Thanks!
    David

  21. lehmangates
    Member
    Posted 6 months ago #

    I'm having the same non-functioning problem. I tried to compose a simple pop up with one rule (popover seen less than x times) but nothing is working. I've read through this thread but I'm a newbie so I'm not sure I can follow along with html solutions. I'll try though.

    I'm using Green Earth WP theme and WP 3.8.1. What else do I need to let you know to work through this issue?

    TIA,
    Gail

  22. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hiya Gail,

    No worries about the technicalities, I'm sure we could walk through that if needed. But I'd like to ask, could you first try switching to Twenty Fourteen theme and see if the pop up shows up with that?

    If it does, it's related to the theme and we could proceed from there.

    Thanks!
    David

  23. Isaacx
    Member
    Posted 6 months ago #

    @David

    Hello David and thank you again for your help.

    My popup is really simple, there is just one sentence in it (no html or javascript). I put only one condition "visitor is logged out" (so the pop up should display everywhere on the website).

    I would like to share the link with you but since I run an adult website I'm not sure about puting the link here and be rude.

    I guess the problem isn't that easy to solv :/

    Thank you anyways!..

    Isaac

  24. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Isaacx,

    It's rather tough to troubleshoot this one without a link but yeah, it wouldn't be good to post that one here.

    If you wouldn't mind granting access through an admin account I could have a look on-site to see what the trouble is.

    If so, you can send through our contact form here:
    http://premium.wpmudev.org/contact/

    1. Select "I have a different question".
    2. For the subject, enter "ATTN David".
    3. For the description, include a link to this thread with the account details.

    I can have a look once I get that.

    Or alternatively, you could use a browser like Chrome and when visiting the page type Ctrl-Shift-J to open the console. Any errors there will be noted in read. If you could post those back here that could help.

    Something else worth asking too, are you viewing the site as a logged out user?

    Thanks,
    David

  25. Isaacx
    Member
    Posted 6 months ago #

    Hello David,

    I don't mind granting you access to the admin account but I would need your IP to do that (otherwise you couldn't access to the wp-login page), maybe you can send it to me by mail ? isaac@geek-x.com)

    I have also tried (logged out), to load the page and the console doesn't seem to show any error (except this line maybe ? : event.returnValue is deprecated. Please use the standard event.preventDefault() instead. )

    Thank you very much for your time.

    Isaac

  26. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi there @Isaacx,

    That does present a difficulty! :)

    If you could contact us through link I provided previously, I could touch base with you that way and get further information over to you from there.

    One thing I should check on as well though, did you try viewing the site as a logged out user?

    I realize it's a simple one, but it's sometimes overlooked.

    Cheers,
    David

  27. David
    WPMU DEV Support Staff
    Posted 5 months ago #

    Hi @Isaacx,

    Just wanted to post back here as we've sorted this through email. The URLs need to be specified with the protocol as well, so http:// in this case.

    Glad we were able to get that sorted, thanks for working with me on that. :)

    Cheers,
    David

  28. mpurpora
    Member
    Posted 5 months ago #

    Hi,

    I seem to be having the same problem. I've tried the different loading options you provided here. I've tried editing the URL to include the back slash and not or removing http://.

    The rule I am using is on a specific URL so visitors can view the pop-up on the homepage only.

    What else can be done??

    http://www.josephitepastoralcenter.org/

  29. David
    WPMU DEV Support Staff
    Posted 5 months ago #

    Hi @mpurpora,

    Really sorry I missed this, since the thread is marked as resolved it's not easy to notice updates and I happened to somehow skip past the notification in email.

    Fortunately, I can see the popover when visiting your home page and not on other pages.

    Was this sorted already?

    If not, just let us know. We'll be here to help. :)

    Cheers,
    David

  30. mpurpora
    Member
    Posted 4 months ago #

    David,

    Thank you. It did seem to start working after the sites cache cleared.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.