WordPress.org

Ready to get started?Download WordPress

Forums

ITRO Popup Plugin
[resolved] PopUp keep showing on every reload (10 posts)

  1. michael_nsc
    Member
    Posted 12 months ago #

    I`ve installed ITRO plugin, and its amazing!

    But I want to show my popup only on the first time the visitors load my home page.

    I set the next visualization hours to 168 (the popup should appears once a week), but nothing happens. Every time I reload my homepage, the popup show up.

    How may I fix it?

    http://wordpress.org/extend/plugins/itro-popup/

  2. ITRO Team
    Member
    Plugin Author

    Posted 12 months ago #

    Hello,
    please can you post your site url?

  3. michael_nsc
    Member
    Posted 12 months ago #

    Shure!

    http://gravandoemcasa.com

    Man, I figured out that WP Super Cache is the problem. When I actvate cache, the popup keep showing.

    Then, I deactivate cache and the popup stops. And, if I activate cache again, the popup stop showing forever!

    I dont know how to configure WP Super Cache to handle this problem.

  4. ITRO Team
    Member
    Plugin Author

    Posted 12 months ago #

    We have analyzed the problem and seem that WP Super cache cause many problems with cookies. We adivice to deactivate it or try another similar plugin.
    Our plugin set a cookie via JavScript and make a control via $_COOKIE array, a very simple and clean thing.
    We are sorry but we can't help you.
    Please try to ask for some support to enable cookie, to WP Super Cache author.

    PS:
    We have tried WP SC plugin in a virgin site with all basic settings and WP debbugger print this warning:
    Notice: Undefined variable: cookies in ******\wp-content\plugins\wp-super-cache\wp-cache-phase1.php on line 641

  5. ITRO Team
    Member
    Plugin Author

    Posted 12 months ago #

    The only two way (for now) are to set "Cache disabled" in WP Super Cache, or disabling the entire plugin.

  6. KunststoffWeb
    Member
    Posted 10 months ago #

    I'm facing a similar problem with "W3 Total Cache".

    There the popup shows up only on the front page (although I selected "all pages"), but not on other pages (even when you first visit a subpage). It show up every time you visit the front page although I set up next visualization in 24 hours.

  7. ITRO Team
    Member
    Plugin Author

    Posted 10 months ago #

    Hello,
    have you tried to disable W3 plugin or to disable chaching? Thank you

  8. yourkiller
    Member
    Posted 5 months ago #

    So in the end, this plugin doesn't work with caching?

  9. ITRO Team
    Member
    Plugin Author

    Posted 5 months ago #

    Please try last version and give us a feedback. Maybe we have fixed the problem with caching.

  10. swapnil131
    Member
    Posted 3 months ago #

    Hello i need to display pop up two times per visitor is it possible?
    Please help

Reply

You must log in to post.

About this Plugin

About this Topic