WordPress.org

Ready to get started?Download WordPress

Forums

WP Stripe
Popup Calling non https styles (3 posts)

  1. Jeremiah
    Member
    Posted 1 year ago #

    I'm having an issue with this plugin calling non https styles. When the Enable SSL for modal pop-up? option is set to yes, I get this error:

    [blocked] The page at https://wpovernight.com/wp-content/plugins/wp-stripe/includes/stripe-iframe.php?keepThis=true& ran insecure content from http://wpovernight.com/wp-content/plugins/wp-stripe/css/W.wp-stripe-display.css.pagespeed.cf.FXVMkkL5l0.css.

    Basically, looks like the styles are being blocked, and the form looks pretty bad.

    When it's set to no, Everything looks fine. I was getting the same message for the other stylesheets, but I was able to go into the plugin code and manually change them to call them via https. Can you please let me know how to call http://wpovernight.com/wp-content/plugins/wp-stripe/css/W.wp-stripe-display.css.pagespeed.cf.FXVMkkL5l0.css via https. This stylesheet doesn't seem to exist, nor is it called by any files, from what I can tell.

    http://wordpress.org/extend/plugins/wp-stripe/

  2. bu7k
    Member
    Posted 1 year ago #

    in my case thickbox doesnt work ..no pop up..
    EDIT// i switched to twenty eleven and pop up works but not the below ssl issue..

    Whats required in the theme to get the pop up to work?

    in console "the page at... ran insecure content from

    wp-stripe/css/wp-stripe-display.css?ver=3.5.1.
    wp-stripe/css/wp-stripe-widget.css?ver=3.5.1.
    wp-stripe/css/wp-stripe-thickbox.css?ver=3.5.1.
    wp-stripe/js/wp-stripe.js?ver=3.5.1.

    all these are loading with NO SSL even tho i have it checked and i have ssl! In the source they show as http not https..

    Can anyone chime in hear ? Any thoughts?

  3. bu7k
    Member
    Posted 1 year ago #

    Ok so im fixed... I installed the WordPress HTTPS (SSL) plugin and now the "ran insecure content" error and the form not being styled in chrome when ssl is ticked on is gone! The form/page is under ssl!

    i had an issue with the pop up not working but i found an error in my theme that fixed it all.. popup works!

    SSL works with plugin mention by plugin author!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.