WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Pop Up Message In User Dashboard (6 posts)

  1. Dan & Jennifer
    Member
    Posted 1 year ago #

    WordPress version: 3.5
    WordPress SEO version: 1.3.4.3

    I did this:
    1. set the MultiSite Settings
    Who should have access to the BlogPress SEO settings: SuperAdmins Only

    2. Logged in as an Admin to a network level blog (sub-site)

    I expected the plugin to do this: nothing - only super admins should see anything related to WordPress SEO.

    Instead it did this: "Pop-up message in user dashbaord"
    Help us improve WordPress SEO
    You've just installed WordPress SEO by Yoast. Please helps us improve it by allowing us to gather anonymous usage stats through PressTrends.

    When the user clicks on this link they are taken to the WordPress error page
    "You do not have sufficient permissions to access this page."

    Is there any way to remove this message from member blogs in the multisite?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. pdunn
    Member
    Posted 1 year ago #

    I am having the same problems. Cannot get those pop ups to go away. Now they block the menu.

  3. pdunn
    Member
    Posted 1 year ago #

    I disabled google libraries and it corrected the problem.

  4. Dan & Jennifer
    Member
    Posted 1 year ago #

    Did you disable them for this plugin only?

    We were able to disable it (without breaking other wordpress functionality or removing other needed libraries) by just commented out a single line in the class-pointers.php file - and it stopped the "pointer" from loading.
    wp-content/plugins/wordpress-seo/admin/class-pointers.php

    Screenshot: http://www.screencast.com/t/CWs32lhBpWcV

    But that's not a solution - editing plugin files is always a bad solution, because on the next plugin update, this file will be overwritten, and you'll have to edit it AGAIN. And WordPress SEO is updated almost daily. :-)

    @Yoast - PLEASE fix this bug that so many people are seeing. :-)

    I love this plugin but currently can't use it for our blog hosting site (multisite environment) because of this issue.

  5. billzy
    Member
    Posted 1 year ago #

    I needed to have Use Google Libraries and Yoast WordPress SEO on at the same time.

    Disable Google Libraries.
    Click the Close button on the pointers
    re-enable google libraries.

    Yes if you update you need to do that again but on the bright side no need to edit core plugin code...

  6. Dan & Jennifer
    Member
    Posted 11 months ago #

    @billzy - that sounds like it would work fine for a single WordPress install - problem is disabling this pop-up pointer for a network with lots of blogs...

    Does anyone have a solution to disable the pop-up pointer without having actually edit the plugin code as above?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic