WordPress.org

Ready to get started?Download WordPress

Forums

Polylang with Graphin theme: can't update language's text direction (8 posts)

  1. BestLecture
    Member
    Posted 1 year ago #

    Hello,

    After upgrading WordPress to 3.5.1 and upgrading Polylang to latest version (1.0.3) from version 0.8.7 (I think), we had to remove polylang since the upgrade was from too older version. We re-install it.

    We have two languages, English (LTR) & Hebrew (RTL).

    The problem is that we can't update the text direction - when pressing "Update", this specific definition is not being updated (others like "order" are).
    http://dl.dropbox.com/u/58211187/polylang-text-direction.png

    This is the website:
    http://www.gary-tv.com/garymain/?page_id=8 (Hebrew)
    http://www.gary-tv.com/garymain/?page_id=2132 (English)

    In addition, the home URL (http://www.gary-tv.com/garymain) is not being directed to the Front page (http://www.gary-tv.com/garymain/?page_id=8) but rather gets a language parameter (http://www.gary-tv.com/garymain/?lang=en) and results in page not found.

    Any help will much appreciated.
    Thank you very much.

  2. Chouby
    Member
    Posted 1 year ago #

    The problem is that we can't update the text direction - when pressing "Update", this specific definition is not being updated (others like "order" are).

    I don't see any problem on your site. Hebrew is rtl and English ltr as it should.

    In addition, the home URL (http://www.gary-tv.com/garymain) is not being directed to the Front page (http://www.gary-tv.com/garymain/?page_id=8) but rather gets a language parameter (http://www.gary-tv.com/garymain/?lang=en) and results in page not found.

    How did you setup your language switcher?
    What did you set for "front page displays" in "Reading settings"?

  3. BestLecture
    Member
    Posted 1 year ago #

    Thank you for the quick response.

    The Hebrew is partially RTL.
    The main menu (and also the top icons) is left to right.
    http://dl.dropbox.com/u/58211187/LTR-menus.png
    (left menu item is the front page)

    As for the second part:
    The language switcher was not set. I set it now:
    http://dl.dropbox.com/u/58211187/language-switcher.png

    The Front page has no mirror page in English (on purpose).
    Reading settings:
    http://dl.dropbox.com/u/58211187/reading-settings.png

    Thank you!

  4. BestLecture
    Member
    Posted 1 year ago #

    Hi,

    The RTL issue has been solved, I added the rtl.css file using if/else condition in the header file. It wasn't added by default, I guess since the language is set to LTR (since we can't update the 'text-direction').

    The one problem we still have is that our WordPress home (http://www.gary-tv.com/garymain/) leads to 'page not found' after adding a 'lang' parameter by default (http://www.gary-tv.com/garymain/?lang=en).

    Thank you.

  5. Chouby
    Member
    Posted 1 year ago #

    The Front page has no mirror page in English (on purpose).

    That is the problem. Polylang expects a translation of the home page. If it does not find one, it will backup to the list of posts. But here your site is made of only pages, so you get the 404.

    Could you explain what is your goal?

  6. BestLecture
    Member
    Posted 1 year ago #

    Okay, I understand.

    The http://gary-tv.com/garymain/ URL is the "more info" page of the root page (http://gary-tv.com) which features a lecture.

    Previously, the "more info" button referred to garymain/ . Now we changed it to refer to a specific page.

    So overall it is a minor problem, right now.

    Thank you for your hard work on this wonderful plugin.

  7. BestLecture
    Member
    Posted 1 year ago #

    Hi again, since our update, every time a post is being edited (including new posts), all the tags (and categories) are being lost.

    Are you aware of this issue?

    (I can open a new thread if you want)

    Thanks.

  8. BestLecture
    Member
    Posted 1 year ago #

    The last version solved the text-direction bug, thank you.

    We also managed to work around the tags+categories problem by deactivating and reactivating the plugin.

    One last issue, before our upgrade from 0.8.7 to 1.0.3, our home page URL was http://www.gary-tv.com/garymain. Now we can't set it to be the same, the URL is always the full URL: http://www.gary-tv.com/garymain/?page_id=8
    This results in much fewer FB likes to the page.

    Is there any work around to this issue?

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic