WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Polylang slows down the pages generation (2 posts)

  1. Razique
    Member
    Posted 4 months ago #

    Hi Chouby,
    Lately I was trying to optimize my WP installation since it was very slow
    for instance the homepage takes about 6 to 8 seconds to generate,
    Using WP-Cache, it takes milliseconds, and with all plugins disabled except polylang; it's from 3 to 4 seconds every time.

    This is not related to the database since by using debugging tools, all DB requests (around 130 or so) are rendered in less than 0.5 seconds.

    I've tested on the same environment a fresh install of WP and imported all my posts and medias (using the XML importer), without polylang. For this installation, the page renders from 1.5 to 2 seconds - with all plugins enabled back (expect Polylang).

    Now I may be saying wrong things; but is it possible to have some sort of "caching" for Polylang that would I dunno, maybe remember which pages are supposed to be displayed in French and which ones should be displayed in English.

    According to you; what you generate such loading time?
    i've tried to disable permalinks; but it did nothing.

    Here is my configuration:
    https://www.dropbox.com/s/lp6kiyzhk1ef1sd/Screen%20Shot%202014-03-01%20at%2020.58.58.JPG

    Thank you.

    Have a good one and thanks for this fantastic plugin!

    https://wordpress.org/plugins/polylang/

  2. Razique
    Member
    Posted 4 months ago #

    so: looks like it's not really Polylang (well Polyland definitely adds an overhead, which is normal) but it's Wysija actually (a newsletter plugin) that REALLY slows sown the generation.

Reply

You must log in to post.

About this Plugin

About this Topic