WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] polylang newbie-error message (22 posts)

  1. Wordwright
    Member
    Posted 1 year ago #

    Hi,

    Have been learning wordpress while setting up my own site and have just installed Polylang (the site is English/French.) It works really, really well. Thanks to the person who designed it.

    There's just one little problem. I have English as my default language. When I click on the French option, the first thing that comes up is an error message. However, all the content is there, once you click on the appropriate menu items (Accueil, A Propos, Services, Contact.)

    I'm using is a child theme I created based on TwentyEleven, with a static front page. I hope you don't mind me asking a question that's probably been asked before. I'm not particularly technical, so could really use some help.

    Here is a link to the page: http://wordwright.ca/wp/?lang=en

    Thanks in advance.

    http://wordpress.org/extend/plugins/polylang/

  2. Ov3rfly
    Member
    Posted 1 year ago #

    FYI: Tried to send you an email, but the given email address on your contact page is not working: "550 No Such User Here"

  3. Wordwright
    Member
    Posted 1 year ago #

    That's another, seperate thing I'm trying to work out... If you leave a message here it will go directly to my e-mail. Thanks for any help.

  4. Ov3rfly
    Member
    Posted 1 year ago #

    Have left a comment on your website, get in touch with me via the email given there. You'll find it at Comments after you log into your WordPress backend.

  5. Wordwright
    Member
    Posted 1 year ago #

    Hi,

    I'm sorry, I guess I must have misunderstood the forums. I can't pay for advice, as I'm on a tight budget and have just started up my own business. (That's why I have been building this page myself.) I've worked really hard to learn wordpress, and think I haven't done too badly considering I've only been at it for about a week. I am however really stuck on this one particular problem, and do need some advice. If anyone could offer me some help here on the forum, I'd really appreciate it. Thanks.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    @Ov3rfly: Please do not use these forums as a way to solicit paid work. We do not allow that here.

  7. Ov3rfly
    Member
    Posted 1 year ago #

    @esmi: No problem, just offered to take a closer look at the whole site of Wordwright to find and fix the described problem and asked for temporary WordPress admin-credentials in private for this.

    Added a note that a small donation for my help would be nice, and I would provide a PayPal email at a later time.

    I often help out people with their WordPress installs, problems, bugs etc. in my spare time for free - see my community contributions here:
    http://wordpress.org/support/profile/ov3rfly

  8. Ov3rfly
    Member
    Posted 1 year ago #

    @Wordwright: How to track down a WordPress problem:

    1. Disable all other plugins besides Polylang (if any)
    2. Activate standard Twentyelven theme instead of your child theme
    3. Resave your Permalinks, which means: Open this page in admin area: "Settings -> Permalinks" and click "Save Changes"
    4. Check if the problem still persists

  9. Wordwright
    Member
    Posted 1 year ago #

    Thanks for clearing that up, I guess I misunderstood.

    So, back to my original question...It may seem a bit simplistic to more experienced wordpress users, but I've only been working with wordpress for about a week, and while I've made a lot of progress, I am having trouble with an error message that comes up when I switch from English to French. This is the message that comes up :

    "Toutes nos excuses, mais votre requête pour cette archive n’a donné aucun résultat. Peut-être aurez-vous plus de chance en lançant une recherche..."

    Interestingly, the same does not happen when I switch to English from French. As well, all the content is there in both languages. So, Francophones can navigate the site...but the message might end up causing confusion. I know that this must be a problem on my end, and not with Polylang itself, but I could use some help resolving this.

    I am using a child theme I created from TwentyEleven, with a static front page. Here is the page: http://wordwright.ca/wp/?lang=en

    Here are my settings:

    Default language: English

    Browser Language: When the front page is visited, set the language according to the browser preference (check-marked)

    The language is set from content. Posts, pages, categories and tags urls are not modified. (check-marked)

    Remove /language/ in pretty permalinks. Example: http://wordwright.ca/wp/en/ (check-marked)

    When using static front page, redirect the language page (example: http://wordwright.ca/wp/en/) to the front page in the right language (check-marked)

    Activate languages and translations for media (check-marked)

    I've left all of the synchronisations options check-marked.

  10. Ov3rfly
    Member
    Posted 1 year ago #

    Does the problem still persist after you follow the 1. to 4. list?

  11. Wordwright
    Member
    Posted 1 year ago #

    Thanks for the advice. I have just followed all of those steps, and unfortunately there's no change.

  12. Ov3rfly
    Member
    Posted 1 year ago #

    If I check the site, you child theme is still active (see step 2.), also some other plugins are still active (see step 1.)

  13. Wordwright
    Member
    Posted 1 year ago #

    Yes, I re-activated them after I followed the four steps you suggested and found no change. I have just gone back and repeated the steps you suggested, just to make sure...still no change.

  14. Ov3rfly
    Member
    Posted 1 year ago #

    Ok, can see it now. Did you change files in Twentyeleven parent theme?

    Would now try to uncheck "The language is set from content." and "Remove /language/ in pretty permalinks", then do Step 3. and 4. again.

    Then as next testcase with above unchecked, in Settings -> Permalink Settings select Day and Name and save changes, then 4.

  15. esmi
    Forum Moderator
    Posted 1 year ago #

    Added a note that a small donation for my help would be nice, and I would provide a PayPal email at a later time.

    And that's where you definitely crossed the line. You either offer help freely (ideally via these forums rather than in private) or you don't help at all.

  16. Ov3rfly
    Member
    Posted 1 year ago #

    Please do not use these forums as a way to solicit paid work. We do not allow that here.

    And that's where you definitely crossed the line. You either offer help freely (ideally via these forums rather than in private) or you don't help at all.

    @esmi: To avoid possible future misunderstandings, could you please post a link where I can read these forum rules? Thanks.

  17. Wordwright
    Member
    Posted 1 year ago #

    For some reason, I can't seem to uncheck the boxes mentioned. However, while I was checking out the settings, I took a look at the reading section. It's set to a static front page, with a welcom message in English. As an experiment, I switched the front page to the French message "Beinvenu" and went back to the site. Lo and behold, there was no problem with the French side, but then the English front page just gave a generic message about wordpress and first post. I hope this is an extra piece to the puzzle. Once again, thanks to everyone who's taking the time to answer a question from a newbie. I really appreciate it.

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    could you please post a link where I can read these forum rules?

    http://codex.wordpress.org/Forum_Welcome It's linked to in the
    welcome message at the top of every forum.

  19. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Seen as a visitor, you created your pages in French and your pages in English but they are not linked together.

    When you look at the page list table, for the French page "accueil" - there is a typo on your site ;-) - you should see a pencil in the column showing the British flag. If you see a +, it means that your French page is not linked to its English counterpart.

  20. Wordwright
    Member
    Posted 1 year ago #

    I just looked at my page list table, and all the pages have a + instead of a pencil :S So, um at the risk of sounding stupid...how do I get the pages to link up?

  21. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    When you have a page without translation, you create a new translation by clicking the + in the page list table or by clicking "add new" in the language metabox in "edit page"

    Since you have already written a page and its translation, you can link them by:
    1. finding the id of one page (when you edit a page, you are directed on a new url : yoursite/wp-admin/post.php?post=15&action=edit. Here 15 is the id of the page you are editing.
    2. Edit the translation, enter the id in the page id field in the languages metabox. Click on update.

  22. Wordwright
    Member
    Posted 1 year ago #

    Yay, it worked! Thank you so much for taking the time to explain that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic