WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Polylang - links leading to wrong language on responsive theme (1 post)

  1. harpo4
    Member
    Posted 2 years ago #

    Hi, I am using polylang for the first time. Great job.

    I am using this theme,
    http://www.obox-design.com/demo-theme.cfm?theme=knead

    and I am building the site in two languages, english (en) and spanish (es). My default language is spanish and I am using post name permalinks.

    As you can see, the theme's home page is using a widget to feature the three different services from the "Services" page, an when you click on each one leads you to the right service. The issue I am having is that when I am on the spanish site (http://localhost:8888/language/es/) and click on one of them it takes me to the english version (http://localhost:8888/solutions/?view-service=por-que-video-2). Actually there is no content on it, I guess because the right link would be (http://localhost:8888/soluciones/?view-service=por-que-video-2). It seems is mixing the english page and the spanish post. It actually works fine when I am in the english home page (http://localhost:8888/language/en/), it takes me to (http://localhost:8888/solutions/?view-service=why-video-2) which is the right place.

    I have tried deactivating polylang and everything works fine, so I guess is the pluggin what is causing that?

    Regards,

    Pablo.

    http://wordpress.org/extend/plugins/polylang/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic