WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
PolyLang - Issue with Slider, Languages get mixed up (5 posts)

  1. tappeser
    Member
    Posted 1 year ago #

    While I really love this plugin, the slider on my front page does not work as it should with Polylang.
    I have a static frontpage set up, which itself switches fine between English (default and German.
    The slider, which draws its pictures from the featured images in custom slider posts, however mixes up the languages. I tried fixing it by unpairing the different pictures in the slider posts (the pictures are chosen by means of a slider category in the settings of the page, which is language sensitve,e.g. language separated categories are activated), as well as disactivating the syncing of featured images, but that didnt help (at least not for this problem).
    If I unpair the English Homepage from the German Homepage, the sliders in each work fine, but I get an error when trying to go to the homepage in the German version. It seems to have to do with some metadata that is synced between those two pages then, but I would not have a clue how to go sort this out. Any help would be gladly appreciated. The website is http://www.rootability.com the theme is called performs.

    http://wordpress.org/extend/plugins/polylang/

  2. tappeser
    Member
    Posted 1 year ago #

    to specify...
    what happens, is that the slider remains in one language, until I open the static page set as home page in the other language and chose the slider picture category from a dropdown menu (it only gives me All categories and the language specific category that I put the pictures of that language in). Once I chose the category, it works fine, but not anyomore in the other language, where it reverts back to all categories, e.g. it syncs that setting.

    I have a similar issue with a custom field in another section, but there its not so sensitive because I could unpair the entries and avoid the problem (not so elegant, but working). Is there a way to just turn off all these syncs (i found the code you posted to disable the featured image sync, but that doesnt do the trick)

    Cheers,

    Valentin

  3. darakk
    Member
    Posted 1 year ago #

    i have the same problem, i posted too but in french here:
    http://wordpress.org/support/topic/probleme-avec-option-de-page?replies=2

  4. darakk
    Member
    Posted 1 year ago #

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    There is now a simple way to disable synchronization. Go to Polylang settings and uncheck the corresponding checkbox.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic