WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
polylang Home page error (13 posts)

  1. hkatzman
    Member
    Posted 1 year ago #

    Polylang problem

    Home page gives "500 Internal Server Error." If I link to any other page, everything works well. If I remove Polylang plugin, then home page (static page) works fine.

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Did you translate your static front page?

  3. hkatzman
    Member
    Posted 1 year ago #

    Thank you for your response.

    Because the website is not fully functional and is just in experimental stage, not all pages are fully translated. From out experimentation, I believe that we need the static home page translated for this to work.

    Your response seems to confirm our guesses. Thank you.

  4. hkatzman
    Member
    Posted 1 year ago #

    I have been going through this further.
    I want a static front page.

    Under Settings/Reading
    Front page displays ...

    if I use "Your Latest Posts"
    returns with wordpress page of "Nothing Found"

    if I use "A static page" and give a Front page
    returns with "500 Internal Server Error"

    The chosen page has a translated version tied to it. When I am able to link to it, it does go to the translated version when I switch languages.

    (http://www.BirthDoulahJerusalem.com)

    In the languages settings panel, it is not possible to check the
    option 'Redirect the language page to the homepage'.

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    if I use "Your Latest Posts"
    returns with wordpress page of "Nothing Found"

    Did you create any post in that language?

    In the languages settings panel, it is not possible to check the
    option 'Redirect the language page to the homepage'.

    It works only when using a static front page

  6. hkatzman
    Member
    Posted 1 year ago #

    At present,
    using latest posts, I get Nothing Found (but at least the site loads).

    If I use
    static front page
    with a page that has a translation at the front page
    and a blank posts page,
    I get a 500 error (an error that does not allow the site to load at all).

    Maybe you could suggest initial settings for language settings and reading
    that would allow me to use a static front page and do not need any posts page. I wish to make a website, as opposed to a blog site.

    Thank you for all your assistance.

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    If I believe the other post http://wordpress.org/support/topic/plugin-polylang-attempted-access-of-home-page-gives-500-internal-error , you are using a child theme of Bouquet. I tested Bouquet with static front page, and various settings for Polylang and never got an error 500. WP 3.4.2 + Polylang 0.9.4 + Bouquet 1.0.1

    I don't know what you modified in your child theme so can't know if the problem comes from these modifications.

    Very often, the error 500 is caused by a wrong PHP version, so I ask again my question. What is your PHP version?

  8. hkatzman
    Member
    Posted 1 year ago #

    PHP Version:
    5.3.13

    Bouquet child theme is very simplistic ...

    ...

    #access,
    #search-area {
    display: none;
    }

    Yes, the other post was describing the same, but we agreed to consolidate the message to this post so that this would not be competing and get confusing.

    Thank you for your understanding.

  9. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    So let's go on on this post. PHP version should be OK. Child theme too.

    In the other post, I read that the site can produce an error 310 (too many redirects). This is typical from a plugin conflict. Could you try to deactivate all your plugins except Polylang and then activate them one by one and check which one is creating the conflict?

  10. hkatzman
    Member
    Posted 1 year ago #

    I don't know about the error 310. But I cleared everything out and started afresh. There are no plugins at present, except for Polylang.

  11. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    How do you install WordPress? Is the package supplied by your webhost or did you upload WordPress yourself using ftp?

    Could you post the content of your .htaccess file?

  12. hkatzman
    Member
    Posted 1 year ago #

    The webhost provides a package "simple scripts" that loads wordpress.

    .htaccess :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  13. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    your .htaccess looks correct.

    I know that sometimes packages supplied by webhosts create problems and so would not recommend using it (although I don't know how it could affect the combination wordpress + polylang). Have you the possibility to upload WordPress using ftp?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic