WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Polylang: doesn't show my translated pages (10 posts)

  1. WillyWortel19
    Member
    Posted 1 year ago #

    I installed the plugin, set everything to english, default language is english. And I started adding a new homepage in Dutch. But when i select the dutch language in the widget it still shows the default english homepage. I read your whole documentation, but i cannot figure out why my site won't show my new homepage (in dutch) when i select Dutch as language.

    I have day and name permalink settings, don't have a static frontpage and have as default language for everything English. I'm using a theme i bought from themeforest which has .mo and .po files (and which is language ready according to theme-check)

    I would appreciate your help! Thanks in advance!

    Wouter

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try with another theme (twenty ten) and with other plugins deactivated?

  3. WillyWortel19
    Member
    Posted 1 year ago #

    Yes I tried with Twenty Ten theme and it works. So i suppose it's a problem with my Theme? But it has .po and .mo files included. I'm not very good in coding and things so i thought it would be fine to use the Polylang plugin?

  4. smartmobilesigns
    Member
    Posted 1 year ago #

    no i haven't tried at all because its has occur new style css

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Yes the .mo file is a 'must' for Polylang to translate your theme strings. The problem is that I can't imagine all the tricks done by plugin or theme authors to reach their goals. Thus some of them still need adaptations to work with Polylang. But to be honest, it's much harder to help with Premium themes since I can't access them.

    What is the theme?

    How do you create the homepage with this theme? Is it through theme options? Is it a standard page that then you define as static front page in settings->reading? Some other way?

  6. WillyWortel19
    Member
    Posted 1 year ago #

    The theme name is Salutation, bought from Themeforest, made by parallelus.
    The homepage is created by Layouts. So i think it has to do something with the layouts? I already made a new layout with a translated page as default, but that didn't worked...

  7. Japh
    Member
    Posted 1 year ago #

    Hi WillyWortel19,

    For support with a ThemeForest theme, please contact the author of that theme. You can do this from the contact form on the author's ThemeForest profile page. In the case of the Salutation theme's author, that's here: http://themeforest.net/user/Parallelus where they also list a link to dedicated product support.

    Good luck! :)

  8. digihulpdienst
    Member
    Posted 1 year ago #

    Hello,

    I guess I have the same problem. I tried all the standard solutions (switching to Twenty Ten, switching off all plugins, tried all different settings for polylang.

    My WP language and standard language for the site is Dutch. Translations for English, French and German. http://www.letuilier.com

    When I add a translation of a page that is already existing in Dutch, it does not show in the page list, needed to create a menu item. See screenshot

    The theme of the website is Weaver II.

    Please advice

  9. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Is the languages (Talen in your screenshot) menu in the admin toolbar on top of your screen pointing on Dutch? If yes, then you should choose another language (or all languages).

  10. digihulpdienst
    Member
    Posted 1 year ago #

    It was pointing on Dutch only.... Problem solved! Thanks a lot!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags