WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Polylang conflict with Custom Post Type Permalinks (7 posts)

  1. X_Y
    Member
    Posted 6 months ago #

    If you have both of them activated, custom post types added to the navigation menu will have weird links. E.g. the actual link is /en/my-ctp/mypost, while showing up as /en/en/home/my-ctp/mypost, and leads to 404.

    The way of circumventing it is to activate Custom Post Type Permalinks, set the permalink structure to your desired way, and deactivate it. This way everything will work fine.

    It took me quite some time to figure out the solution, could be helpful for people with similar problems.

    http://wordpress.org/plugins/polylang/

  2. iheartwine
    Member
    Posted 4 months ago #

    But after deactivating the CPT Permalinks, all changes made within will be discarded :/

  3. Hans Magnus Mikalsen Nedreberg
    Member
    Posted 4 months ago #

    I have a similar problem:
    http://utvite.org/en/projects/

    Trying to access one of the posts gives 404:
    http://utvite.org/en/projects/second-test-project/

    Is this a problem in my custom post setup, or in the Polylang settings?

  4. Chouby
    Member
    Plugin Author

    Posted 4 months ago #

    My own test show that both plugins are totally incompatible, resulting in fatal error when activated together.

  5. Hans Magnus Mikalsen Nedreberg
    Member
    Posted 4 months ago #

    I thought I read just "Custom Post Types", so I didn't see the Permalinks part.
    Sorry, my bad.

    In my case it happens in regular custom post types, so the problem occurs there too.

  6. X_Y
    Member
    Posted 4 months ago #

    My version of Polylang is 1.4dev17
    Custom post type Permalinks 0.9.5
    Wordpress 3.8.1

  7. Chouby
    Member
    Plugin Author

    Posted 4 months ago #

    @X_Y I tested only both latest versions of plugins. That's possible that the fatal error was introduced in between.

    In my case it happens in regular custom post types, so the problem occurs there too

    Most probably another conflict. Test with no other plugins activated and a default theme such as twenty twelve and please open a new topic not to pollute this one.

Reply

You must log in to post.

About this Plugin

About this Topic