WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Polylang breaks Bretheon theme (7 posts)

  1. gillbates21
    Member
    Posted 1 year ago #

    Polylang doesn't work 100% with this theme (http://themeforest.net/item/bretheon-premium-wordpress-theme/4001061)

    - breadcrumbs will break, showing only last child (works when polylang is deactivated)
    - theme's content builder items can't be translated
    - theme's header items can't be translated (different phone needed for second language)

    polylang vesrion is 1.1.1
    dev site here http://gillbates.ultraleet.net/wordpress-sites/powersteel/

    how should i continue to start debugging/fixing the issues?

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    For the breadcrumbs, I suggest that you use Breadcrumb NavXT.

    Your theme claims to be WPML ready. So if some items can't be translated in the Languages->strings translations panel, it most probably means that the theme author did not forecast them to be translated since it's up to the theme to choose what can be translated and what can't. Just ask him how you could add these items to the list of translatable items.

  3. gillbates21
    Member
    Posted 1 year ago #

    i had breadcrumbs turned to display:none, it is somehow working now :)
    thanks for a quick answer, great plugin

  4. gillbates21
    Member
    Posted 1 year ago #

    again, thx for your input, WPML will get a chance to prove itsself.
    but keep up the good work

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    OK. Let me know if WPML does translate out of the box the items that Polylang did not translate.

  6. gillbates21
    Member
    Posted 1 year ago #

    WPML works well, even out of the box, but it's many settings take a little time to configure correctly. And so many addons.

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you very much for your feedback. Some plugins / themes are using undocumented WPML functions. Maybe it's the case of yours. Or maybe a Polylang bug ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic