WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Polylang and Yoast Seo (8 posts)

  1. stronicowy
    Member
    Posted 1 year ago #

    Welcome,

    When I have two plugins activated: Polylang and Yoast, I have en error:

    Error 310 (net::ERR_TOO_MANY_REDIRECTS).

    I have got this only on my home site. Please tell me what i have to do to make it clear and work.

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Could you activate only WordPress SEO and Polylang and use a default theme such as twenty twelve to check that the conflict is not coming from elsewhere?

    Could you precise your Polylang and permalink settings, as well as if you are using a static front page? Are you using WordPress SEO default settings or did you make changes?

  3. stronicowy
    Member
    Posted 1 year ago #

    Thanks for your answer :)

    "Could you activate only WordPress SEO and Polylang and use a default theme such as twenty twelve to check that the conflict is not coming from elsewhere?" - I have done it and still is the same error.

    WordPress permalinks settings: http://mysite.com/%postname%/

    My home page is not a static page. My home page has two loops. Each of them list last posts for tags. When i change my home page on static page, there isn't error. But I don't want use a static page for home:(

    WordPress SEO: I have my settings, not default...

    ...But i setting default Yoast settings and now everything is ok. Why? I don't know...

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    If you find which settings of WordPress SEO and Polylang conflict, then I will be very interested to know and will try to find a workaround.

  5. stronicowy
    Member
    Posted 1 year ago #

    OK, I will put in one by one new settings WordPress SEO, save this and check my site. I will tell you, when it is not working. Promise :)

  6. stronicowy
    Member
    Posted 1 year ago #

    Here is the answer:

    When I check "Redirect ugly URL links" in Yoast SEO, then i have Error 310 (net::ERR_TOO_MANY_REDIRECTS).

    That's it :) I'm stille using Yoast SEO but I disabled redirect ugly links. Now everything is OK!

  7. stronicowy
    Member
    Posted 1 year ago #

    Problem is solved.

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Could you explain how you did solve the issue?

    Working on it, I believe that I found the reason for the conflict. WordPress SEO did not receive the homepage url in the correct language from Polylang. So I tried to solve it in the current development version. It should also solve a related issue, as the home url was not correct in the menu "SEO->Analyze this page".
    http://downloads.wordpress.org/plugin/polylang.zip

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags