WordPress.org

Ready to get started?Download WordPress

Forums

polylang (14 posts)

  1. biblestoriesreadalong
    Member
    Posted 2 years ago #

    Hi!

    I am fast learner…(I don't know much now.. almost nothing) so question might be too general…

    I took website somebody already created and have to add Russian Pages
    The person installed Polylang plugin , I follow all the suggested procedures, but it is not working for wp I need to add russian pages. How should I go wit that?

  2. Elan Technosys
    Member
    Posted 2 years ago #

    The polylang wordpress plugin is working fine for me you can see it here noortekeskus.kodulehetegemine.ee did you added Russian language in plugin settings?

  3. biblestoriesreadalong
    Member
    Posted 2 years ago #

    Yes I did many times… here is a table showing how it looks and ???? suppose to be the Russian word

    Take a look:
    Full name
    Locale
    Code
    Order Flag
    Posts
    Full name
    Locale
    Code
    Order Flag
    Posts
    ???????
    ru_RU ru 1 0
    English
    en_CA en 0 0
    2 items

  4. Elan Technosys
    Member
    Posted 2 years ago #

    Can you post your URL?

  5. biblestoriesreadalong
    Member
    Posted 2 years ago #

    Hi!
    This is my training url
    http://webtailor.ca/lena/?lang=ru
    as you can see it has polylang and it has russian menu, but when I am trying to post in Russian it all ?????

  6. Elan Technosys
    Member
    Posted 2 years ago #

    Yes I saw your site and it is quite simple create a page in Russian and copy its page id for example "67" and paste it to its English version or in your default language version yo can see an option on the right side before Publish section you need to add there your page id and then publish it.

  7. Elan Technosys
    Member
    Posted 2 years ago #

    And for navigation menu go to menus create a menu and then go to plugin settings page and select one menu for your one language and second for your second language it will show menu on two different languages.

  8. goya873
    Member
    Posted 2 years ago #

    HI,

    I've installed polylang on my work in progress website using templatic "widgetized" theme home page. My default language is French and second language English. Since there isn't 2 separate home pages (1 for french and 1 for english) polylang does not add the english language switcher at the end of the menu. It only shows the french. How can I fix this ?

    http://outawebs.ca

    Otherwise, fantastic plugin.

  9. Elan Technosys
    Member
    Posted 2 years ago #

    @goya873:
    it is easy first install the plugin and configure the language after configuring add a page in English and change the permalink to example.com/?page_id=25 like that just copy the page id from English page and add to your french and copy page id from french to English page and save them now you can change your permalinks back it worked for me hope it will work for your.

  10. goya873
    Member
    Posted 2 years ago #

    Thanks Elan, that work great. I have only one last problem... when navigating using http://www.outawebs.ca (instead of only outawebs.ca) the home page shows both languages content on same page. Any trick for that ?

    Thanks for your help, much appreciated.

  11. Elan Technosys
    Member
    Posted 2 years ago #

    I didn't used webhosting theme so I'm not sure where issue is but if you are using widgets for content on home page then of you add a widget for English version select a option at the bottom of that widget some thing like "This widget is for language select English" for English and select French for French home page.

  12. goya873
    Member
    Posted 2 years ago #

    That is not the issue. The issue is when navigating to the site URL with or without the "www". It seems that Polylang looks at the WP-Admin / General Settings / Site Address (URL), and properly assigns multilangual settings based on that. Will display proper default language content browsing to http://www.outawebs.ca if above Site Address(URL) setting is identical. Now try navigating with browser using http://outawebs.ca, it will show both languages on the page with strange combined menu.

    The opposite is also true if change WP-Admin / General Settings / Site Address(URL) to http://outawebs.ca. Then if I navigate using http://www.outawebs.ca everything goes bad.

    Tried removing entry in Global Settings / Site Address (URL) in the hope that Polylang will respond properly to either http://www.outawebs.ca or http://outawebs.ca but WordPress give error "The Site address you entered did not appear to be a valid URL. Please enter a valid URL."

    Hope I'm able to explain this correctly.

    Thanks so much.

  13. Elan Technosys
    Member
    Posted 2 years ago #

    I understand your problem you want site should look same if we see it with "www" or without "www" I didn't tried that because I added a redirect so if a user type site url with "www" it will be redirected to without "www" url but thanks to tell I'll find about it.

  14. Chouby
    Member
    Posted 2 years ago #

    This is a bug. Could you try with the development version ?
    I hope it corrects this.

Topic Closed

This topic has been closed to new replies.

About this Topic