WordPress.org

Ready to get started?Download WordPress

Forums

BadgeOS Community Add-on
[resolved] Points not working (2 posts)

  1. danielclaytonwelsh
    Member
    Posted 10 months ago #

    Hi.

    I've created levels of achievements. First the user has to achieve a few simple tasks. After completing these they are awarded a badge. Each badge also comes with 5 points. I have created 4 badges each that award 5 points.

    I have also created an achievement called prizes. I have made a prize that states the user needs to get 20 points to get the prize.

    I have created a user who has achieved all four badges and thus has made 20 points. However no achievement comes up in the activity or achievements section if they they have achieved the 20 point prize. Nothing, as if they haven't achieved it.

    I created another achievement that awarded a prize if the user achieves all 4 badges. This worked. Ideally though we want the points to work. Am I doing something wrong?

    http://wordpress.org/plugins/badgeos-community-add-on/

  2. Michael Beckwith
    Member
    Plugin Author

    Posted 10 months ago #

    Hmm. The first thing that stands out for me is a question of how you got your test user to the 20 points. Did you do it via the admin user doing the awarding in the admin area? Or did you have the user go through the process that others would? I'm curious if the different ways to get to the same end result aren't triggering the same way, if that's the case.

    Also, what version of BadgeOS and WordPress are you on. Also is this with badges related to the community addon? I noticed you posted in two places, so I want to make sure I'm testing with the correct components instead of say just badgeos when it's a community addon issue.

Reply

You must log in to post.

About this Plugin

About this Topic