WordPress.org

Ready to get started?Download WordPress

Forums

Pods - Custom Content Types and Fields
[resolved] pods doesnt work after update to 2.3 (20 posts)

  1. afreyer
    Member
    Posted 1 year ago #

    hi,

    today, i got the message, that new version of pods is available. ok, i made its update processing and anything seems to be fine.
    But i went to my single post, there are images as thumbs placed (image fields of pods), but only one (the last) of images was shown and some jquery effects (galleriffic) didnt work.

    Downgrading to version 2.2 fixed this issue. what can i do? somebody, who has also problems with new version?

    regards
    andré

    http://wordpress.org/extend/plugins/pods/

  2. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    What code are you using for your images in your single post?

    Also, have you tried Pods 2.3.1 at http://pods.io/latest/ yet?

  3. afreyer
    Member
    Posted 1 year ago #

    i show it by the way with meta entries:

    <?php //pods images
    if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <?php $images = get_post_meta( $post->ID, 'arbeiten' );
    foreach ( $images as $image )
    	{
    	$testtitel = get_the_title(); echo '<li style="float: left;list-style: none;"><a title="'.$testtitel.' - '.$image['post_title'].'" class="thumb" href="'.$image['guid'].'">'.pods_image( $image, 'arbeiten-navi' ).'</a>
    
    <div class="caption">
    
    	<div class="image-desc"><p>'.$image['post_title'].' » '.$image['post_excerpt'].'</p></div>
    	</div>
    </li>';
    	}
    ?>
    <?php endwhile; ?>
    <?php endif; ?>
  4. afreyer
    Member
    Posted 1 year ago #

    ok, update process of wordpress shows me only the version 2.3 NOT 2.3.1!! why?

  5. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    Pods 2.3.1 is still in progress, you can get it from http://pods.io/latest/

  6. afreyer
    Member
    Posted 1 year ago #

    I'll try it again..

  7. afreyer
    Member
    Posted 1 year ago #

    do you think that my code is right?

  8. afreyer
    Member
    Posted 1 year ago #

    i ve uploaded it to the plugin folder, but i cant find it at the plugin page of wp options..

  9. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    Upload the contents of that folder over the existing pods folder in your plugins folder.

  10. afreyer
    Member
    Posted 1 year ago #

    i ve deleted the old folder before uploading the new one.

  11. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    Make sure the new plugin folder is named 'pods'

  12. afreyer
    Member
    Posted 1 year ago #

    yes it is.

  13. afreyer
    Member
    Posted 1 year ago #

    i tried it again:
    1. 2.2 up
    2. overwrite it with version 2.3.1
    --> white screen in back- and frontend..

  14. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    In your wp-config.php, set define( 'WP_DEBUG', true ); and let me know what errors you are seeing in your back or frontend.

  15. afreyer
    Member
    Posted 1 year ago #

    ok, please wait a moment. i downgraded to v2.2 again. i ve to update it again.

  16. afreyer
    Member
    Posted 1 year ago #

    cant believe it. i did the same process, but now i can see pods plugin in backend!!
    but after i checked it for activating, errer message: plugin couldnt activate, because there was a fatale error. (in german: Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt.)

    This message occured in debug and in non debug mode.

    sorry, but i have to work on my page. i will downgrade to v2.2 and can wait. ok?

    thank you for supporting me.

  17. Scott Kingsley Clark
    Member
    Plugin Author

    Posted 1 year ago #

    OK, no problem. I'll take a look into what might be causing that fatal error for you. I'm not seeing it on my side on any of the projects I'm using 2.3 and have upgraded from, so I'll keep an eye out.

  18. afreyer
    Member
    Posted 1 year ago #

    thanks a lot. you did a good job. i work since last 2 or 3 weeks with pods. its possibilities are fantastic!

  19. afreyer
    Member
    Posted 1 year ago #

    maybe, if i have finished my work at the end of this week, we can check it again together..

  20. afreyer
    Member
    Posted 1 year ago #

    ok, today i tried again with wp-internal updater and all seems fine.

    thank you..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.