WordPress.org

Ready to get started?Download WordPress

Forums

Podpress Player showing up twice on my posts (11 posts)

  1. btsdl
    Member
    Posted 3 years ago #

    My WordPress website is a WooTheme. Working very well so far. For some reason, Podpress player is showing twice on my podcasting posts. Can you help?

  2. ntm
    Member
    Posted 3 years ago #

    Which podPress version do you use?

    Does this happen on all the pages or maybe only if you view a single post?

    Do you use the [display_podcast] shortcode to position the podPress elements in the post?

    What is the "Location" setting in the Post Content section of the General Settings page of podPress? End? Start?
    Does it change something if you change this setting?

    What is the "Always before the <!- More -> tag:" setting in the Post Content section of the General Settings page of podPress?
    Does it change something if you change this setting?

    Does this also happen while all other plugins are deactivated?

    Regards,
    Tim

  3. ntm
    Member
    Posted 3 years ago #

    Which WooTheme is it?

  4. ntm
    Member
    Posted 3 years ago #

    Okay, I have found the link to your blog and saw the posts.

    The Share This buttons and the second player is in a part of the page which is called the "post-content" (<div class="post-content">) and the description of the podcast episode and the first player is in a part which is called "intro" (<div class="intro">).
    Where do you enter the description? Is it the excerpt box below the post editor? Do you use the [display_podcast] shortcode to place the player at this position?

    I have found the name of the plugin. It is the Backstage theme.

    Regards,
    Tim

  5. btsdl
    Member
    Posted 3 years ago #

    Hey Tim. Thank you for taking the time to get back to me.
    We are using version Version 8.8.9.1
    This happens on all the posts.
    Im not sure about the [display_podcast] shortcode.
    Location setting is "End". When I change the location setting to "Start", it goes before the description, but the second player still shows. Funny how the second player showing up is indented, where the first player is on the left. Also, when I switch to "Start" the second player goes above the "share" plugin. Hmm, interesting.
    The "Always before tag" is set to no, if I switch to yes it still shows up twice (second one indented again.
    I don't know what happens if the other plugins are deactivated. If I deactivate the other plugins I'm afraid I will lose content, maybe not?
    We enter the description in the excerpt box below the post editor.
    Not sure if I use the [display_podcast] shortcode or not. I'm new at this one.

    I appreciate any more feedback you can give.
    Thank you Tim.

  6. btsdl
    Member
    Posted 3 years ago #

    I forgot we lost the ability to post comments, even though the boxes are checked.

    Thanks Tim.

  7. btsdl
    Member
    Posted 3 years ago #

    Might help if I give you the url to see:

    http://www.breakthesilence.com

  8. ntm
    Member
    Posted 3 years ago #

    Thank you for your answers.
    Other plugins are most likely not responsible for the doubled appearance of the podPress player elements.

    We enter the description in the excerpt box below the post editor.

    That helps to understand the problem. The template of these pages which show one show are showing the excerpt of a post and the post content at once. In my experience that is a little bit unsual. The other themes I know are displaing the excerpt instead of the content and sometimes only on special pages like category overview pages. But why not.

    podPress adds the player and the other elements to the content and to the excerpts and in your theme which displays the excerpt and the content on same page, the player gets added twice on that page.
    That is so far the default behaviour and no bug.
    But I have added a new option to the current Development Version of podPress which lets you choose whether the podPress elements should be attached to the content and the excerpt OR to the content sections only OR to the excerpts only.
    You can find it at the General Settings page of podPress in the Post Content section.

    I would appreciate it if would try this version.

    The problem with the comments has most likely nothing to do with podPress.

    But it might be possible that it has something to do that you enter the description of your episodes into the excerpt box instead of the main input field of the post editor. Maybe if a post has no content then it does not show the comment form.
    Or maybe the template for that page does not offer a comment form.

    May I ask why you enter the description of a episode in the excerpt box instead of the main input field of the post editor?

    Regards,
    Tim

  9. btsdl
    Member
    Posted 3 years ago #

    Weird thing is that the double player popped up before we entered any text in at all.
    Now we tried 3 different ways to post on the homepage, using different widgets. Now some of the text is only coming up as hyperlinks. Maybe something is wrong with the script. At this point it looks like I keep digging deeper and cant get to where I want. I'm still getting an old test post in my RSS also, even though it isn't posted anymore. I'm pretty stuck here and don't know where to go. Should I uninstall PodPress and try the Development Version? Maybe I should start everything over? I believe the description was entered into excerpt box because the text came up looking better. I'm lost and frustrated now. Sorry to be a pain Tim.

  10. ntm
    Member
    Posted 3 years ago #

    Dave, you are NO pain!

    Yes, please use the current Development Version. It has a new option which will help you with the doubled player.

    Now we tried 3 different ways to post on the homepage, using different widgets. Now some of the text is only coming up as hyperlinks.

    Maybe you should insert the post content as you have done it before and ask the makers of the theme for help in the meantime. That is probably a matter of the theme or the widgets.

    I'm still getting an old test post in my RSS also

    That is a different problem. Which RSS do you mean? The http://www.breakthesilence.com/feed/ looks fine to me. But http://www.breakthesilence.com/feed/podcast/ does not contain posts. That is why it might not appear as valid.
    The problem is maybe that you have selected a wrong file type in the file type filter. Maybe m4a or another file type and since you post only mp3 files, the Feed contains no posts. Try to de-select the selected file types by holding the [Ctrl] key and by clicking with left mouse button.

    BTW: It is possible to view a RSS Feed in a web browser. But in most cases it is necessary to clear the browser cache memory to view the recent changes.

    Regards,
    Tim

  11. btsdl
    Member
    Posted 3 years ago #

    Who is the man? TIM is the man! It works, thanks to you. Did a lot of touch ups and updates too. My next podcast will be Monday, and Tuesday I will spread the word and go live! Check it out, I enjoy harsh criticism if you see anything let me know.

    Only thing is I still can't get the comments to work. I will post on this site and the WooThemes site and hopefully get some feedback.

    I can't thank you enough Tim.

    Dave

Topic Closed

This topic has been closed to new replies.

About this Topic