WordPress.org

Ready to get started?Download WordPress

Forums

podPress
itunes not updating but stitcher and the rest are (2 posts)

  1. pdpodcast
    Member
    Posted 6 months ago #

    *** DISCLAIMER ***
    ***** MY PODCAST HAS ADULT MATERIAL ON IT> DO NOT CLICK IF THIS OFFENDS YOU *****

    I had podpress working great. But then I created a post with 4 different podcast within it. Itunes did not recognize any of them. So I then deleted the post and created a new post for each podcast. Itunes still does not see the updates.

    If I look at my feed:

    http://www.porndirectorpodcast.com/main/?feed=podcast

    it is very slow but eventually comes up.

    If I try and validate it I get a "Server Timed Out"

    http://feedvalidator.org/check.cgi?url=http://www.porndirectorpodcast.com/main/?feed=podcast

    if I use other validators I get success:

    http://castfeedvalidator.com/?url=http://www.porndirectorpodcast.com/main/?feed=podcast

    I get a "< HTTP/1.1 200 OK" when I curl the url.

    is the speed of my feed causing the lack of update? if so how do I speed this up?

    All the best
    CoN

    http://wordpress.org/plugins/podpress/

    [ Please do not bump, that's not permitted here. ]

  2. ntm
    Member
    Plugin Author

    Posted 6 months ago #

    If the iTunes Store page of your podcast is not updating at all then the Server Timed Out message may indicate the cause.
    The HTTP/1,1 200 OK answer says only that the server of your podcast is answering the the request but I could observe that the server is slow. I tried the feed validators myself and used the URL of your podcast feed. they all had problems with this slow speed.

    But one can load your feed with the browser and copy/paste the XML source code of the feed into the special field of another validator http://validator.w3.org/feed/#validate_by_input

    I have done this and would say that the feed is in a okay shape. The validator stated that is valid. But you may deactivate the function "Print podPress elements into the <content:encoded> tags" (on the Feed/iTunes settings page > section Further Feed Settings). Deactivating this will reduce the amount of data in the feed and maybe reduce the download time a little bit. But you should also talk to your hosting provider.

Reply

You must log in to post.

About this Plugin

About this Topic