WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Podpress file path problem (5 posts)

  1. bravenewniche
    Member
    Posted 5 years ago #

    I thought I've entered the paths correctly in the PodPress settings and in the Location field of the post itself, but I get this as the download URL:

    http://mydomain.comhttp//www.mydomain.com/wp-content/podcasts//wp-content/podcasts/20081007.mp3

    In the General Settings, URL of media directory, I have:

    http://www.mydomain.com/wp-content/podcasts

    and in the Location field for the post itself I have:

    /wp-content/podcasts/20081007.mp3

    I've tried just entering the mp3 file name, but it automatically reverts back to this path...

    Any ideas? Couldn't find anything in the podpress documentation, and it seems like I'm doing what the popup help says within podpress...

  2. bravenewniche
    Member
    Posted 5 years ago #

    I changed the WordPress URL in the WordPress settings, and added http://www., which changed that first http://mydomain.com to http://www.mydomain.com, so clearly podpress is using the WordPress settings to inject the base URL for the site - so why is it asking for a full URI in the podpress settings???

    Going to try changing podpress general settings to give only the path from root to the podcast file folder...

    Well, that's the answer to that question.

    1. Podpress uses the URL in your WordPress settings
    2. In podpress General Settings, enter the URI as /root/to/files/

    Now, presumably we only need to add the file name in the actual post, under Location....

    Tried that, but it keeps reverting to

    /wp-content/podcasts/20081007.mp3

    when I re-save the post.

    Ok, so now I go back and completely clear the URI in General Settings for Podpress.... It works!

    So to recap what actually worked for me:

    1. Podpress uses the URL in your WordPress settings
    2. In podpress General Settings, leave the URI blank
    3. In the individual post, under Location, enter /path/to/podcastfiles/mysounds.mp3

    Counter-intuitive to say the least, but it's working for me.

  3. Dgold
    Member
    Posted 5 years ago #

    Ok, sounds like you're good to go then. Enjoy!]

    For me, under the Write Post > Podpress area > Location field, podpress gives me a nice dropdown menu that shows me all the files in the folder I specified in the settings.

    So it's just a drop-down, point and click to choose the file, for me, with podpress.

  4. bravenewniche
    Member
    Posted 5 years ago #

    After saving that post the second time, I'm now seeing the drop down menu, Dgold. I wonder if, because it was my first MP3 uploaded, that the system hadn't started cataloguing them...??

    However, what I see in the drop down menu is

    /path/to/podcastfiles/mysounds.mp3

    and if I go back to General Settings in PodPress and enter

    /path/to/podcastfiles

    I get the same problem again with having two paths in the final URL in the post, and therefore the file won't load... weird

  5. bravenewniche
    Member
    Posted 5 years ago #

    FOLLOW UP

    So, a few days later and we uploaded a bunch more MP3s - all of a sudden, they're showing up in the drop down menu in Posts, with only the file name and no path whatsoever... Just as Dgold said above.

    Had to go back into General Settings, enter

    http://www.mysite.com/wp-content/podcasts/

    and everything's working fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.