WordPress.org

Ready to get started?Download WordPress

Forums

Podpress Error - Feedcache? (7 posts)

  1. selenakittyn
    Member
    Posted 6 years ago #

    I had to change my theme and uploaded the newest Podpress... now my podcasts won't work. I use premium content (but I made sure "premium content" was checked)

    I think it's an access/issue, but I don't understand these instructions... can someone explain them slowly and clearly?? :) I'd be much obliged!

    Directory Not Valid or Not Accessible
    Suggested: /mnt/w0210/d47/s35/b029af36/www/selenakittyn.com/Blog/wp-content/uploads

    and this:

    Feed CachingFeedcache files will be stored in the follow directory: //mnt/w0201/d47/s35/b029af36/www/selenakittyn.com//Blog//wp-content/uploads/podpress_temp

    If you are using the index.php from optional_files in your main wordpress directory then you should set this value to match the $podPressFeedCacheDir value.

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Is the wp-content/uploads directory there and does it have proper permissions, I'm not sure what these would need to be because I've never used the plugin but I'm sure the author might have some kind of documentation on it.

  3. selenakittyn
    Member
    Posted 6 years ago #

    the directory DOES exist, yes... permissions are chmod 755 (which is standard, I think?)

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I took a look at FeedCache. I'm uncertain why it would be needed, since the purpose of it seems to be to cache external feeds locally for display/usage.

    This sort of thing is already built into WordPress (in what seems to me like a more effective manner), so I'm wondering why not just use that instead?

  5. selenakittyn
    Member
    Posted 6 years ago #

    I'm honestly just looking to get podpress working again... if I could turn off "feedcache" I would... but there doesn't seem to be a toggle to do it! :) All I can see wrong on the page, as I said, are the messages I posted above. And I have no idea how to go about finding out if I'm "using index.php from optional_files"...?? I've googled but come up with nothing... tried to post on the mightyseek podpress forums but the %&$^#*% verification code keeps stopping me. *sigh* Is mercury retrograde this week? Communication seems to be an issue! :)

  6. selenakittyn
    Member
    Posted 6 years ago #

    PS UPDATE: When I try to validate my feed (I use feedburner) it says:

    This feed does not validate.

    line 60, column 115: url must be a full and valid URL: 20http://www.selenakittyn.com/index_files/selenadew115.mp3 (6 occurrences) [help]

    ****

    Is that "20" in front of the http being caused by the wp-cache I installed? If so, how do I fix it??

  7. cpjolicoeur
    Member
    Posted 6 years ago #

    The reason is needed is because the built in wp_fetch using MagPie doesnt perform well under heavy loads.

    The built in functions work well for 1 or 2 feeds, but if you are trying to grab and parse 30+ feeds with everypage load it bogs down.

    Yes, there is also built-in caching with wp_fetch, but still, once every hour (or however long you set the cache timeout) there will be a SUPER LONG page load as all 30+ feeds are updated.

    FeedCache fixes this by doing all the fetching and parsing in the background via CRON jobs. Then all the display theme needs to do is read a txt file and display the contents which results in SUPER FAST page loads.

    I'm not sure what this error with Podpress is, but I dont think its related at all to the FeedCache plugin

Topic Closed

This topic has been closed to new replies.

About this Topic