WordPress.org

Ready to get started?Download WordPress

Forums

Podpress 1pixel-out player not displaying (10 posts)

  1. hrrrbrwl
    Member
    Posted 3 years ago #

    I have searched and tried all the solutions for this problem that are already available on these forums but nothing seems to work.

    I'm not sure when the player stopped displaying but I think it was only in the past couple of weeks. I can't see the player in Chrome, Firefox or IE on this PC or my PC at work.

    I just updated to version 8.8.10.9 of PodPress this morning thinking that would solve my problem but it hasn't.

    I'm running WP3.2.1, Atahualpa 3.6.7 theme.

    Here is a link to my podcast category: http://www.digital-distortions.co.uk/dd/category/brawlcast/

    Any help or suggestions would be greatly appreciated.

    Cheers

    John

  2. ntm
    Member
    Posted 3 years ago #

    Hi John,

    this may not be a bug. it seems to me that you have deactivated the option "Display Player/Preview:" on the Player Settings page of podPress.
    If this box is not checked then you need to click on "Play Now" in the line below the player (at the front page) to make the player (or the player preview) visible.
    There is an comparable option in the podPress box on the post editor page.

    Regards,
    Tim

  3. hrrrbrwl
    Member
    Posted 3 years ago #

    Thanks for the reply.

    'Display Player/Preview' is checked in my player options, if i uncheck it the gap where the player should be disappears when I view the post, the player does not appear but the gap where it should be appears when I re check the box.

    'Disable Preview Player' in the post options does the same, I still cannot see the player in a previewed or published post.

  4. ntm
    Member
    Posted 3 years ago #

    You are right 'Display Player/Preview' is checked in your blog. Sorry, I have not looked into the source code of your blog before.

    If it is not this setting then it is probably Javascript (JS) code of one of your other plugins or the theme which causes an JS error on page load.
    podPress relies on JS to display the player. But if there is such an error on page load then it is possible that other JS code does not work correctly..

    If you open the error console of your web browser, you will see there are JS errors e.g. Syntax error, unrecognized expression: [href$=.mp3] (or Error: uncaught exception: Syntax error, unrecognized expression: [href$=.mp3]). This one is maybe caused by the WPaudio MP3 Player plugin (see http://wordpress.org/support/topic/no-mp3-play-button-just-a-link).
    Deactivate this plugin for a moment to control whether or not it is responsible for this error. If it is the cause then maybe try to fix it like it is described in the other forum thread.

  5. hrrrbrwl
    Member
    Posted 3 years ago #

    I have deactivated and deleted the WPAudio plugin as I no longer need it but it hasn't made a difference, the player stil doesn't appear.

  6. ntm
    Member
    Posted 3 years ago #

    I see. The JS error is gone but player is still invisible.

    I have made a few tests and the problem is most likely that podPress uses since quite some time such HTML comment characters to <!-- --> around the JS section which makes the player visible and it seems to be important that after the first tag follows a line break. Otherwise the Javascript does not work. Well and you seem to use a plugin which shrinks the code of your blog and removes nearly all line breaks and some white-spaces from the source code (If you use e.g. Firefox to view the source code of your blog then you can see that almost all code is in one line.).

    However, these comment characters are not that important and I have removed them. You may install the current Development Version which includes these modifications if you don't want to turn off that code minimizer plugin until the next version of podPress comes out.

  7. hrrrbrwl
    Member
    Posted 3 years ago #

    Weird I don't use a plugin that does that. I'm hardly using any plugins especially ones that modify posts without my knowledge. Maybe it's something to do with the Atahualpa theme? I create most of my posts in HTML view would that make a difference? I wouldn't have thought it made a difference and I've only had this problem recently.

    Anyway, thanks for your help and time. I will give the development version a try.

    Cheers

    John

  8. ntm
    Member
    Posted 3 years ago #

    I'm hardly using any plugins especially ones that modify posts without my knowledge.

    I thought that you maybe use a plugin like this http://wordpress.org/extend/plugins/theme-minifier/ . Maybe there is an option build-in in your theme. I don't know.
    Such plugins don't really modify the posts they compress only the code which the web browser interprets. Programmers use tabs or white space and line breaks to make the code they write more readable. But the web browser usually don't need those elements. Those plugins compress the output code by removing those spaces which are only for humans. That may help to keep the reduce the amount of the transferred data.
    The comment characters have been probably at the wrong place. I need to take a look into the book.

    I create most of my posts in HTML view would that make a difference?

    No, that has most likely nothing to do with the view which you use to edit your posts.

    (BTW: only the file podpress_theme.php is different compared with version 8.8.10.9)

  9. hrrrbrwl
    Member
    Posted 3 years ago #

    It's working with the development version.

    Thanks again for your help. :)

  10. hrrrbrwl
    Member
    Posted 3 years ago #

    Just a quick update on this issue...

    It seems the atuahalpa theme does have a code minimizer enabled by default.

    While researching another problem I had with my site to do with spaces missing from the post titles I found an option within the Atahulapa theme options.

    Under Atahulapa theme options -> CSS & Javascript there is an option called CSS: Compress which by default is enabled. Disabling this made the spaces reappear in my post titles. It also fixed the issue with the 1pixel out player disappearing. from the posts.

Topic Closed

This topic has been closed to new replies.

About this Topic