WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] "podcast" is not a valid feed template (3 posts)

  1. PrestoJeff
    Member
    Posted 1 year ago #

    Hi,

    My iTunes feed is at http://www.thegaminggrunts.com/blog/?feed=podcast , and it's returning "ERROR: podcast is not a valid feed template".

    I'm running podPress 8.8.10.13. I'd been playing around with trying to split apart the "podcast" feed into multiple smaller feeds, and I suspect that's when I broke things.

    I believe I've restored the settings to the "podcast" feed, re-saved on the Permalinks and Widgets pages, but I'm still getting the error page.

    Any suggestions would be appreciated. Thanks in advance!

    http://wordpress.org/extend/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    "ERROR: podcast is not a valid feed template".

    This error message appears when there is no feed with the slug name podcast. This could mean that the feed is not activated or that there is no such feed (the feed has maybe a different slug name).

    However the current problem seems to be something different. This feed exists now (the error message does not appear anymore). But it has no <item>s. I have validated your podcast feed (see http://www.feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.thegaminggrunts.com%2Fblog%2F%3Ffeed%3Dpodcast) and could see that the <channel> element does not include <item> elements. This is the reason why the first error message of the validator is an 404 error.

    The reason that this perticular feed has not items and podcast episodes is maybe a unwanted filter setting.
    For instance it is possible to define that the feed should include only post with attachments of a certain file type. If you would set the file type filter e.g. to m4a and there are no posts with such attachments then the feed would not contain items.

    Please control the settings for the podcast feed again.

  3. PrestoJeff
    Member
    Posted 1 year ago #

    I played around with the filter settings some more, and now things are working. Thank you very much for the help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic