WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugins will not activate (9 posts)

  1. billollib
    Member
    Posted 8 years ago #

    I am running WordPress 1.5.1.2 on a PC running Red Hat Fedora, kernel
    2.6.9-1.667smp athlon i386, served by Apache/2.0.52. WordPress seemed to have installed fine, and I can post, comment, and seem to do whatever I need, *except* none of the plugins seem to activate. When I hit "Activate" on a plugin I get the result "plugin Activated," but the plugin does not seem activated, and the option to *deactivate* does not appear. This occurs with either of the default editors and with an imaging plugin I tried to install.

    Any ideas would be appreciated. Could it be a file ownership/permissions problem? I accidentally changed the ownership of all the files in /var/www to my acct, (I thought I was in my home directory) and then when I noticed it, changed all files in /var/www to be owned by root. I could not find a description of what the file ownerships should be.

    Thanks!

    billo

  2. skippy
    Member
    Posted 8 years ago #

    Files can be owned by anyone, as long as the user account used by the webserver has permission to read them. Personally, I'd rather not have root own the files.

    Can you activate any plugins? Can you download and install a few extra plugins, just to test? It's hard to tell right now whether there's a problem with WordPress, permissions, or the specific plugin(s) you're trying to activate.

  3. billollib
    Member
    Posted 8 years ago #

    I've tried the defaults that came with WordPress -- Hello Dolly, Texture1, Markup, and a couple of image display plugins. It happens on all of them.

    As an aside, just for giggles, I upgraded to WorPress 1.5.3 to see if that did anything. It *did* change behavior.

    Now, when I hit on activate, a blank page comes up, with the URL
    http://www.billoblog.com/billoblog/wp-admin/plugins.php?action=activate&plugin=iimage-browser-plugin.php
    showing as the address.

    If I then go up to the address, click on it and hit return, I get the error:

    Sorry, you need to enable sending referrers, for this feature to work.

    I don't have a clue what that means!

    Thanks,

    billo

  4. skippy
    Member
    Posted 8 years ago #

    A search points to Enable Sending Referrers on the Codex.

    I've not experienced this problem myself, so I can't help much. If you follow the instructions in that link and continue to have trouble, please let us know.

    If the link above helps you fix the problem, please let us know!

  5. billollib
    Member
    Posted 8 years ago #

    No joy. I tried it with both Mozilla and IE, without success.

    I have noticed that I'm generating beaucoups errors in /var/log/httpd/error_log:

    When I first go to the blog url, I get:

    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113
    [client 67.141.179.201] PHP Fatal error: Call to undefined function: wp_footer() in /var/www/billoblog/billoblog/wp-content/themes/default/footer.php on line 17

    When I choose Login and provide the admin name and password, I get:
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-login.php
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-login.php
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-login.php
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-login.php

    When I hit the Plug-Ins tab:
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-admin/
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 32, referer: http://www.billoblog.com/billoblog/wp-admin/
    [client 67.141.179.201] PHP Warning: in_array(): Wrong datatype for second argument in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 77, referer: http://www.billoblog.com/billoblog/wp-admin/
    [client 67.141.179.201] PHP Warning: in_array(): Wrong datatype for second argument in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 77, referer: http://www.billoblog.com/billoblog/wp-admin/
    [client 67.141.179.201] PHP Warning: in_array(): Wrong datatype for second argument in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 77, referer: http://www.billoblog.com/billoblog/wp-admin/
    [client 67.141.179.201] PHP Warning: in_array(): Wrong datatype for second argument in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 77, referer: http://www.billoblog.com/billoblog/wp-admin/
    eaucoups errors in /var/log/httpd/error_log

    (one in_array error for each plugin in the list)

    When I hit Activate, I get:
    [client 67.141.179.201] PHP Warning: Invalid argument supplied for foreach() in /var/www/billoblog/billoblog/wp-settings.php on line 113, referer: http://www.billoblog.com/billoblog/wp-admin/plugins.php
    [client 67.141.179.201] PHP Warning: in_array(): Wrong datatype for second argument in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 9, referer: http://www.billoblog.com/billoblog/wp-admin/plugins.php
    [client 67.141.179.201] PHP Fatal error: [] operator not supported for strings in /var/www/billoblog/billoblog/wp-admin/plugins.php on line 10, referer: http://www.billoblog.com/billoblog/wp-admin/plugins.php

    Does this mean anything to you?

    Thanks,

    billo

  6. skippy
    Member
    Posted 8 years ago #

    So you've cleared your cache, and deleted your cookies?

    When you upgraded to 1.5.1.3, did you upload your files in ASCII mode with your FTP program?

    Make a copy of all the plugins in your /wp-content/plugins/ directory. Then delete all the plugins. Then try to load WordPress again. Does that work?

  7. billollib
    Member
    Posted 8 years ago #

    I'll give it a shot tomorrow and see what happens. Thanks!

  8. skippy
    Member
    Posted 8 years ago #

    Note that when I said "Then try to load WordPress again" what I meant was "then try to access your site again". You don't need to re-upload all your files unless you DID NOT use ASCII mode when uploading the first time around.

  9. billollib
    Member
    Posted 8 years ago #

    Well, I tried all sorts of permutations, and got it to work. What I ended up having to do was switch from Fedora to Mandriva Linux. I *suspect* that there was some security setting in Fedora that I didn't know how to play with -- I have a lot of experience with Mandrake, but little with Fedora, and I have run into hidden security settings before.

    I looked over some previous discussions where people had similar problems, and it was solved by turning off the firewall. I don't want to do that, but I can manage it more easily on Mandriva. I was planning on moving from Fedora to Mandriva on the server anyway, so it wasn't such a big deal.

    In any case, it was likely an OS config issue, not a WordPress issue. It works fine on Mandriva 2005LE Linux.

    Now, all I have to do is figure out how to transfer all the MySQL data from the old installation to the new one...

    Consider this ticket closed. Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags