WordPress.org

Ready to get started?Download WordPress

Forums

Plugins Widget Block & Widget Context broke in 3.2? (3 posts)

  1. stealthkinetics
    Member
    Posted 3 years ago #

    I just updated to 3.2 and then made a change to a widget that used Widget Block (which is a plugin that allows you to specify specific pages for widgets to appear or not appear) and these plugins no longer seem to work.

    Any Widget Block or Widget Context enabled widget that I touch (since updating to 3.2) stops working when targeting by page URLs. It seems like there might be something strange with how the returns are (not) registering in the multi-line fields... maybe something to do with the new admin UI changes?

    Can anyone confirm this behavior with either or both plug-ins before I figure out how to contact the authors? Be glad to provide more info as needed...

  2. Lars Koudal
    Member
    Posted 2 years ago #

    Hi stealthkinetics

    I have the same problem right now. Did you ever figure out a solution?

  3. stealthkinetics
    Member
    Posted 2 years ago #

    Hi Lars, I cannot say I've figured out exactly why this is happening, but I have gotten around it by doing the following:

    Most of my include/exclude rules were previously in Widget Block. I took all those URLs out of Widget Block (and changed it's include/exclude settings) and moved them to Widget Context. I also had to go through and in several cases very carefully check all of the URL lines and/or retype them. It seems there are some strange characters or soft returns or some kind of word wrap issue after the 3.2 upgrade, and URLs may not have been getting recognized as being on a new line as they appear to be in the widget admin.

    So in short, I have abandoned using Widget Block for include/exclude rules, and do it all in Widget Context now.

    I have had to do this on multiple sites I developed/maintain.

Topic Closed

This topic has been closed to new replies.

About this Topic