WordPress.org

Ready to get started?Download WordPress

Forums

Plugins update failure (14 posts)

  1. Lukum
    Member
    Posted 5 years ago #

    Hi,

    I'm using WP 2.7 on two blogs. Until 2.6 I could do automatic updates, now that function fails with a message like:

    Downloading update from http://downloads.wordpress.org/plugin/article-directory.0.9.5.zip

    Download failed.

    The plugin update has failed

    My FTP data are correct, and the plugins directory permissions are fine too. I don't see where the problem comes from, thanks for helping.

    L.

  2. Roy
    Member
    Posted 5 years ago #

    Does this go for ALL plugins? I have one that I can't upgrade either, but I have no problems with the rest. That one plugin, btw., goes under unactivated plugins, I can activate it there and delete the old version.

  3. Dion Hulse
    WordPress Dev
    Posted 5 years ago #

    "Download Failed" isnt affected by your FTP details, or the plugin permissions(They should all be at defaults btw).

    The issue will be related to the new HTTP API which WordPress uses in 2.7 to retrieve external files, Does the Plugin Browser (Plugins -> Add New -> etc) work as expected? Or does that show an error message?

  4. Lukum
    Member
    Posted 5 years ago #

    Answers to Gangleri and dd32:

    - Yes, the issue affects all plugins
    - No, the Plugin browser doesn't work properly when I try to download/install a new extension. I have the same kind of message, "Download failed", and operation timed out. So I guess the same issue affects updates and new installs.

  5. Dion Hulse
    WordPress Dev
    Posted 5 years ago #

    But the plugin browser itself works? (Just the plugin installer doesnt)

    Usually theres a more descriptive error rather than just "download failed" i thought.. not sure why its not happening.

    Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module"

    If you can post the contents of the HTTP Access page (Its a tab along the top once activated) that'd be appreciated.

    You might find disabling which ever item is listed as "GET Primary" will fix the problem for you, (I suspect it'll be cURL), Once you've done that, attempt to upgrade a plugin again, see if it works.

  6. Lukum
    Member
    Posted 5 years ago #

    @dd32: it seems we're on the right track for troubleshooting: I installed the core-control plugin as you said, activated the http module, and I have this:

    PHP HTTP Extension Not Available
    cURL Available Disable Transport | Test Transport Primary GET
    Primary GET(non-blocking)
    PHP Streams Available Disable Transport | Test Transport Primary POST
    Primary POST(non-blocking)
    PHP fopen() Available Disable Transport | Test Transport
    PHP fsockopen() Available Disable Transport | Test Transport

    When trying to Disable transport for cURL, I get a server error:

    Not Acceptable
    An appropriate representation of the requested resource /index/wp-admin/admin-post.php could not be found on this server.
    Apache/2.0.46 (Red Hat) Server at http://www.myserver.org Port 80

    Note that cURL support is enabled in my php settings.
    What does "PHP HTTP Extension Not Available" mean?

    Does that issue have to do with the server settings? Should I ask my provider to disable cURL, or is there another workaround? Thanks.

  7. Lukum
    Member
    Posted 5 years ago #

    Well, here's another useful info. I've got another worpdress blog on another server where automatic plugins upgrade works just fine, and cURL is enabled. That server has php 5.2.4 installed (whereas the other server with the buggy WP installs has php 5.2.6 installed). Also, the server where automatic upgrade works shows the following with the core-control plugin:

    PHP HTTP Extension Not Available
    cURL Available Disable Transport | Test Transport Primary GET
    Primary GET(non-blocking)
    PHP Streams Not Available
    PHP fopen() Not Available
    PHP fsockopen() Available Disable Transport | Test Transport Primary POST
    Primary POST(non-blocking)

    Here the cURL test/disable settings don't end with an Apache error.
    I don't know if that means something, but the server with the automatic upgrade that works has less available functions than the other with the buggy installs...

  8. Dion Hulse
    WordPress Dev
    Posted 5 years ago #

    Sorry about the delay in reply...

    What does "PHP HTTP Extension Not Available" mean?

    The HTTP API supports 5 different methods, Your server doesnt support the HTTP extension, so it cant use it, simple as that :)

    An appropriate representation of the requested resource /index/wp-admin/admin-post.php could not be found on this server.
    Apache/2.0.46 (Red Hat) Server at http://www.myserver.org Port 80

    Is your admin panel at /index/wp-admin/ ? If so, Your WordPress install isn't complete, You'll need to upload the admin-post.php file.

    re-upload the missing file(or maybe more..) and attempt disable curl again, then see what happens.

  9. CarltonBale
    Member
    Posted 5 years ago #

    This is an intermittent problem for me; I solved it by disabling cURL using the Core Control plugin as described above. Here are the details:

    Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module". Go to the new tab fore the "HTTP Module" and test cURL. You will most likely receive the following error message "An Error has occured: name lookup timed out" Now click the "Disable Transport" link in for cURL. You should now be able install plugins and plugin updates.

    Here is the bug report: http://core.trac.wordpress.org/ticket/9998

  10. SkyWriting
    Member
    Posted 5 years ago #

    Using "Core Control" has fixed all my plugin updating delays. Works like lightning now. Thanks!

  11. NetSpider
    Member
    Posted 4 years ago #

    GREAT!!! THANKS!!
    i have disabled "PHP HTTP Extension" (this was not works),
    cURL works fine! =)

  12. ashiado
    Member
    Posted 4 years ago #

    Beautiful! Thank you!! Solved my plugin and WP version update problems and all is working much more quickly too!

  13. balord
    Member
    Posted 4 years ago #

    I was able to workaround the timeout and keep cURL enabled with a little custom plugin code. Read about it over here: http://wordpress.org/support/topic/293871?replies=9#post-1172696

  14. gazouteast
    Member
    Posted 4 years ago #

    I got the problem that the plug-ins auto eupgrade is asking for FTP user login, accepts the details, then just hangs during the unpacking stage

    I tried resetting wp-content to 775 permissions as per another thread - that worked for one plug-in upgrade, then it went back to the same old error.

    Changing the actual plugin folder to 775 as well as wp-content, did not fix the problem.

    So I tried to get Core Control via the plugin installer ... and ran into an identical problem - asked for login, starts unpacking and hangs

    I've searched WP forums and there are hundreds of threads about this - surely the central devs have an "official" fix for it somewhere?

    I've got a bucketful of WP installs, on three continents, with a bunch of hosting services, and so far it's just this one install with the issue (it's wp 2.8.4 so latest version, and this issue surfaced as far back as WP 2.5 but is unresolved - that's four major sub-versions it has existed within).

    Gaz

Topic Closed

This topic has been closed to new replies.

About this Topic