WordPress.org

Ready to get started?Download WordPress

Forums

Plugins think Home page is Posts Page (4 posts)

  1. AmethystZ
    Member
    Posted 1 year ago #

    Hi folks all,
    I have an odd problem I've never seen before on any of my other WP sites. It's a bit odd so bear with me. http://www.nmah.com.au
    Short version: Socialise and WP Float will only work on the Post Page if I also tell them to work on the Home page. Then they work on both. If I uncheck the Home Page but keep the Post Page ticked (which means they should work on the Post page but not the Home page), they wont work at all.
    What seems to be happening is that they think the Home page isthe Posts page when it's not. I have set the Home page as a static page with the blog posts to another page jus like you would do where that was required.
    Any ideas why this might be the case? I'm using Weaver II Pro theme.
    Many smiles,
    Ziggy

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Does this happen with those plugins on a default WP theme? If so, it may be a problem with one or more plugins causing a conflict. If not, it may be theme-related problem, and you should check on the WeaverPro site -- as it's well supported there.

  3. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    Socialise and WP Float will only work on the Post Page if I also tell them to work on the Home page.

    how are you doing the 'telling'?

    are you using a plugin like 'widget logic'?

    are you using conditional tags?

  4. AmethystZ
    Member
    Posted 1 year ago #

    Yep alchymth, I know it will only work on the Post page if you tell it to also work on the Home page but I don't want it to work on the Home page, just the post page. On the WP Float plugin and the Socialise plugin, i was using the plugin to direct which pages to use it on.
    Is there a way to have WP Float and Socialise shown on the Post page but not the Home page at all?
    WPyogi, it doesn't happen on any of my other sites not using this theme so I'm assuming it may be theme related. I've posted a thread on the Weaver site to ask the same question. Wondering if I can resolve it eventually.
    Many smiles to you both for the help,Ziggy :)

Topic Closed

This topic has been closed to new replies.

About this Topic