WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugins not installing after server move. (3 posts)

  1. callum
    Member
    Posted 1 year ago #

    Hi Everyone,

    I was not sure where to post this but I ended up posting it here (obviously)

    I just moved a site from one sever to another. I created a new database and swapped out the relevant info in the wpconfig file. The site is up and running.

    But when I went to install W3 Total Cache it just froze up downloading it. I tryed getting a zip and uploading it that way and then via ftp. neither worked and got this fatal error when attempting to activate the plugin.

    http://pastebin.com/xcNiEk9x

    Im a pretty big novice when it comes to anything code related but it seems to me it does not have the right permissions? But when i created the database i just ticked all the permissions boxes.

    Any help would be appreciated greatly. Also as a side question of sorts, what permissions should i give database for a WordPress site?.

  2. jakilevy
    Member
    Posted 1 year ago #

    Hi @callum - thanks for pasting the code into pastebin.

    I believe you'll need to create some new directories in your wp-content folder :
    /cache/tmp

    This thread might be helpful to you :
    http://wordpress.org/support/topic/after-w3-total-cache-plugin-update-actions-generates-500-internal-server-error?replies=7#post-3923849

    Regarding permissions, you might want to take a look at this article, Changing File Permissions, or submit a separate thread for that as it's not totally related to this plugin.

  3. callum
    Member
    Posted 1 year ago #

    Hi Jakilevy,

    Thanks for finding the time to help. The link has helped me solve my problem.

    Kind Regards,

    Callum.

Topic Closed

This topic has been closed to new replies.

About this Topic