WordPress.org

Ready to get started?Download WordPress

Forums

Plugins Don't install (4 posts)

  1. zorro1965
    Member
    Posted 2 years ago #

    Plugins don't install or auto update.

    after a week of playing around with this AND nobody even offering to answer my question I am seriously considering moving back to Joomla at least the community was well organized and friendly and things worked.

    Yes WordPress has a 5 min install. BUT it DOES NOT MATTER if you can't get the plugins to work right.

    I have searched hours and hours over the past week trying to find a fix.

    What I have found instead is many people first offering what is nothing more then a workaround solution.

    They say "if plugins install does not work then manually upload"

    That is not fixing the problem and also takes away form simplicity of using WP.

    Next I also have see when trying to install a plugin an error that says "Directory already exist" even know I look via FTP in the plugin directory and there is no such directory.

    Problems problems to even get just simple start going. I thought that WP was supposed to be simple and you didn't have to be a developer to use it.

    I also thought the community was supposed to of help to one another.

    Guess I was wrong on all accounts...!

    Over a week and no response at all to my other post http://wordpress.org/support/topic/ftp-plugin-auto-install-or-upgrade-not-working?replies=1

    Zorro...!

  2. Jonathan Dingman
    Member
    Posted 2 years ago #

    You should talk to your web host to ensure that your web server is configured properly. Not all web hosts are setup to do the auto-update or interface install of plugins. You may have to manually update them if your web host doesn't support it.

  3. dotch
    Member
    Posted 2 years ago #

    I know what your mean, I'm quite new to WP also and was also dissapointed; installing WP is easy, but after the initial setup you run into all kinds of problems. Many of the problems I encountered where related to file permissions. I haven't seen this with other cms's and I think the devellopers should find a user friendly solution for this.

    Use an FTP prog (Filezilla works great and is free) to change the file permissions. Try setting (chmod) the wp-content folder to 777 and the plugin folder to 775. If that does mot work, try temporary turning php save mode off, if your host allows you to do this. If that doesn't work, set all wp-content folders AND files to 777; but don't forget to set it back to 755 for security reasons.

    That's how I got the plugin system to work. Also read this.

    Good luck!

  4. Jonathan Dingman
    Member
    Posted 2 years ago #

    I understand your frustration and it's something I've had heartaches with as well. It definitely is an area I hope is improved in the future (file permissions and uploading)

    I definitely suggest NOT leaving your permissions set to 777, that's very insecure and can leave your site open to hackers fairly easily.

    I would consult your web host for help. Any half decent web host will offer up some help in resolving these kinds of issues.

Topic Closed

This topic has been closed to new replies.

About this Topic