WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugins And Internal Error 500 (14 posts)

  1. DocEroc
    Member
    Posted 4 years ago #

    On my local setting, no problems with certain plugins.

    On my live site for a client, a couple of plugins, when trying to activate them, will throw an INTERNAL ERROR Try Again Later.

    I went through and deactivated everyone and still only certain ones.
    htaccess files SEEM ok, nothing changed on them.

    I use 1and1 if that helps/matters.

  2. DocEroc
    Member
    Posted 4 years ago #

    AHH I found out how to fix it! Got to put this in the bottom of your htaccess file:

    Options All -Indexes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
  3. aar0on
    Member
    Posted 4 years ago #

    Great advice! I kept getting an Error 500 when I clicked the Pages link in the Admin panel. Adding this at the bottom of the .htaccess got rid of the error.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    Options All -Indexes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
  4. ILoveToSing
    Member
    Posted 3 years ago #

    How do I edit the .htaccess page? I'm using Filezilla for my FTP (if that helps). Thanks.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

  6. ILoveToSing
    Member
    Posted 3 years ago #

    Thanks, Esmi. I got it figured out. My Notepad was not the default editor and every time I would right-click, choose edit/view, my computer tried to open the file in Photoshop (weird). Anyway, I created a new file with the script from aar0on (above) and it worked.

  7. zer0ruth
    Member
    Posted 3 years ago #

    ***WARNING***

    I just did what was outlined above and it seriously screwed up my website.

    I've been desperately trying to find a solution to this 500 Internal Server Error and thought that this was the solution, but after I changed my .htaccess file to the above, it changed every link on my site and my admin. Instead of linking you to a page when you clicked on it, it would download that page to my desktop. I quickly changed the .htaccess file back to it's original state, and that problem stopped immediately.

    Unfortunately, the 500 Server Error, is still around.

  8. Andy01
    Member
    Posted 3 years ago #

    Hmm. I just edited the .htaccess file by the following instructions and had no problem. Before, I had to disable all plug ins, but for me this seems to have done the trick for now, we'll see what happens when I re-install the plug ins I deleted earlier. Thanks for this info!

  9. kfx
    Member
    Posted 3 years ago #

    check your theme and its compatibility. i had the same issues and after deactivating K2 everything else worked just fine.

  10. hornitosmonster
    Member
    Posted 3 years ago #

    I'm getting this error and I tried this fix and my results were the same as zer0ruth. I had to change it back. My site is loading super slow and I'm getting the Internal Error 500 quite often.
    Here is my site
    http://www.fightweek.com

  11. hornitosmonster
    Member
    Posted 3 years ago #

    My theme (and plugins) worked great until today.

  12. zer0ruth
    Member
    Posted 3 years ago #

    hornitosmonster, are you hosted with GoDaddy? I've been struggling with this problem for months now, and I've tried everything. The only thing I hadn't tried was hosting a mirror of my blog with different host to see if that was the problem. Turns out I only get a Internal Server Error 500 when my site is hosted at GoDaddy. I was curious to see if anyone else had that problem.

  13. hornitosmonster
    Member
    Posted 3 years ago #

    Not hosted on Go Daddy. I'm Hosted on Dreamhost. I found my issue and fixed it. It actually had to due with my site going over memory limits on the shared server (can't afford my own server at the moment).

    However, it was not Fightweek going over the memory limits, it was two very old and abandoned PHPBB messages boards I used on Hardcore Boxing. Ads bots were registering for the board at an alarming rate (no post were being made because all accounts had to be approved).I also stupidly left the search option open to anyone viewing the site (guest, etc.)

    Dreamhost suggested that I add captcha to my boards and limit search to logged in users to combat the Bots. I just shut down and closed up the boards because I was not using them anymore. That took care of my issue.

  14. srichand
    Member
    Posted 3 years ago #

    hey DocEroc,

    Thanks man you saved my day!!!!!!!:)

Topic Closed

This topic has been closed to new replies.

About this Topic