WordPress.org

Ready to get started?Download WordPress

Forums

plugin.php causing an infinite loop (10 posts)

  1. pilot911
    Member
    Posted 10 months ago #

    My error log is growing huge with the following:

    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  ksort() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 397
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  reset() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 401
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  next() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 408
    [Sat Sep 21 00:42:25 2013] [error] [client 63.7.101.106] PHP Warning:  current() expects parameter 1 to be array, integer given in /usr/home/mysite/domains/mysite.com/public_html/wp-includes/plugin.php on line 404

    Any idea what is causing this. I saw a previous post from 1 year ago which is similiar but not exactly the same:

    http://wordpress.org/support/topic/pluginphp-and-wp_filter-causing-an-infinite-loop?replies=2

    Any help/advice is greatly appreciated.

    Thanks

  2. pplong
    Member
    Posted 10 months ago #

    I'm experiencing exactly the same issue - creating huge error logs.

    Pilot911 - I've seen this on a number of sites over the last couple of days - one factor that seems to be common to all was NextGen gallery plugin - mind if i ask if you're using it on your site(s)?

  3. pilot911
    Member
    Posted 10 months ago #

    Yes I am using NextGen Gallery plugin.......planning to downgrade to previous stable version.

  4. pilot911
    Member
    Posted 10 months ago #

    Thanks pplong appreciate the heads up....

  5. pplong
    Member
    Posted 10 months ago #

    yes, thinking of doing the same myself. I'd just updated to the latest v.2.0.27 because the previous version appeared to be created massive numbers of identical ngg_delete_expired_transients cron jobs.

    Don't know if it's related, but it can't have helped.

    Could you post back here if you find that rolling the version back fixes the problem? I'll do the same if I happen to get there first.

    thanks

  6. pilot911
    Member
    Posted 10 months ago #

    Just using this post: http://www.nextgen-gallery.com/how-to-rollback-a-version/

    To roll back to 1.9.13 as advised in the comments of this post: http://www.nextgen-gallery.com/nextgen-gallery-2-0/

    Will let you know how i get on pplong.

  7. pilot911
    Member
    Posted 10 months ago #

    Successfully downgraded to 1.9.13 will wait a few months before attempting to upgrade again.

  8. pplong
    Member
    Posted 10 months ago #

    Thanks pilot911 - likewise, rolled back to v1.9.13 and everything has been stable since.

    Appreciate your help

  9. Elan42.com
    Member
    Posted 10 months ago #

    Same for me from today, and I also updated Nextgen Gallery 2 today.

    this is the cause: http://wordpress.org/support/topic/new-bug-filling-up-log-files-taking-down-site-20gig-and-counting/page/2?replies=31

  10. Curtis Pope
    Member
    Posted 10 months ago #

    Same issue, NextGen here as well. (((ugh)))

    It's is downgrading again or moving on for me.

Reply

You must log in to post.

About this Topic