WordPress.org

Ready to get started?Download WordPress

Forums

Zotpress
[resolved] Add Group Account > XML Error (2 posts)

  1. La M
    Member
    Posted 2 years ago #

    There is a bug when adding new Zotero group accounts in WP.

    Steps to recreate:

    1) Create Zotero API:
    Go to Zotero, create a new API Group key: https://www.zotero.org/settings/keys/new
    Untick all Private Library access options
    Select appropriate Group access options
    Save

    2) Create WP Zotpress Account:
    Go to WP Zotpress > Accounts tab (/test/wp-admin/admin.php?page=Zotpress&accounts=true)
    Select Account type "Group"
    Add a user ID as instructed.
    Add a Private Key as instructed
    Add a nickname
    Save

    3) Retrieve feed of Citations from Zotero into Zotpress:
    Go to Zotpress > Citations tab
    Clear Cache

    Result:
    Error message. "Warning: DOMDocument::loadXML() [domdocument.loadxml]: Start tag expected, '<' not found in Entity, line: 1 in admin.default.php on line 257"

    ------------
    Necessary fix:
    Use Zotero GROUP ID and not User ID as instructed by Zotpress.
    Group ID is only available if you make the group private in Zotero and look at its url, instructions aren't provided in Zotpress.

    Would be very helpful if this was made clear in the Zotpress Add Account page (e.g. if field description changed depending on the account type option chosen, plus instructions on where to get it in tooltips.)

    http://wordpress.org/extend/plugins/zotpress/

  2. Katie
    Member
    Plugin Author

    Posted 1 year ago #

    The instructions can be found if you hover over the "?" icon, and are also listed on the Help page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags