WordPress.org

Ready to get started?Download WordPress

Forums

ZenphotoPress
Same images appear multiple time in selection page (8 posts)

  1. LePhasme
    Member
    Posted 3 years ago #

    Hi,
    since the last time I have uploaded photo in my gallery I have a problem with the thumbnails in the selection page to add selected images to my post.
    Some of the images appears multiple times (2 or 3 max to this time), it's seems that the images with the problem have nothing special in common.
    In my gallery all looks good and i didn't change anything in my configuration of zenphoto.
    I tried to regenerate the thumb cache and refresh the database function of zenphoto but the problem is always the same
    Here a screenshot of the problem :
    http://www.upev.net/wp-content/uploads/2010/10/bug-zppress.jpg

    I hope someone can help me...

  2. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    What happens when you click on the duplicated thumbs? Is the code inserted in the post duplicated as well or there are some differences (e.g. in the URLs)?
    Have a look at the post in HTML mode to spot this.

  3. LePhasme
    Member
    Posted 3 years ago #

    There is a difference, the alt and title attributes are filled only on the first thumb.
    For example with a picture duplicated 3 times the result if I insert the 3 is :

    <a href="http://takealook.dreamhosters.com//canada/roadtripest/DSC_2463.jpg"><img class="ZenphotoPress_thumb " alt="DSC_2463" title="DSC_2463" src="http://takealook.dreamhosters.com//canada/roadtripest/image/thumb/DSC_2463.jpg"  /></a>
    
    <a href="http://takealook.dreamhosters.com//canada/roadtripest/DSC_2463.jpg"><img class="ZenphotoPress_thumb " alt="" title="" src="http://takealook.dreamhosters.com//canada/roadtripest/image/thumb/DSC_2463.jpg"  /></a>
    
    <a href="http://takealook.dreamhosters.com//canada/roadtripest/DSC_2463.jpg"><img class="ZenphotoPress_thumb " alt="" title="" src="http://takealook.dreamhosters.com//canada/roadtripest/image/thumb/DSC_2463.jpg"  /></a>
  4. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    Strange. Try enabling debug mode and see what it tells you. I'm especially interested in the response from the ZenphotoBridge call.
    http://wordpress.org/extend/plugins/zenphotopress/faq/

  5. LePhasme
    Member
    Posted 3 years ago #

    It give me that

    ZenphotoPress Messages
    
    INFO
    
    ZPP Version: 1.7.3
    
    INFO
    
    PHP Version: 5.2.14
    
    INFO
    
    Current working directory: /home/lephasme/upev.net/wordpress/wp-content/plugins/zenphotopress/tinymce
    
    INFO
    
    POST: Array ( [what] => thumb [what_custom_text] => [link] => image [link_custom_url] => [close] => true [imgperpage] => 10 [orderby] => sort_order [wrap] => none [size] => default [custom_width] => [custom_height] => [album] => 7 [album_name] => Road trip est [album_url] => canada/roadtripest [zenphotopress_web_path] => http://takealook.dreamhosters.com/ [zenphotopress_admin_dir] => zp-core [mod_rewrite] => 1 [page] => 14 [toggle_what_status] => closed [toggle_link_status] => closed [toggle_close_status] => closed [toggle_order_status] => closed [toggle_wrap_status] => closed [toggle_size_status] => closed )
    
    INFO
    
    GET: Array ( [tinyMCE] => 0 [section] => image )
    
    INFO
    
    ZenphotoProxy method: cURL
    
    INFO
    
    zenphotopress_custom_show: 10
    
    INFO
    
    zenphotopress_custom_orderby: sort_order
    
    INFO
    
    ZenphotoProxy call: http://www.upev.net/wp-content/plugins/zenphotopress/zenphoto_bridge.php?albumid=7&function=get_album&data_path=/home/lephasme/takealook.dreamhosters.com/zenphoto/zp-data
    
    INFO
    
    ZenphotoProxy call: http://www.upev.net/wp-content/plugins/zenphotopress/zenphoto_bridge.php?albumid=7&sort=sort_order&start=130&limit=10&function=get_images&data_path=/home/lephasme/takealook.dreamhosters.com/zenphoto/zp-data
    
    INFO
    
    ZenphotoProxy call: http://www.upev.net/wp-content/plugins/zenphotopress/zenphoto_bridge.php?albumid=7&function=count_images&data_path=/home/lephasme/takealook.dreamhosters.com/zenphoto/zp-data
    
    INFO
    
    ZenphotoProxy call: http://www.upev.net/wp-content/plugins/zenphotopress/zenphoto_bridge.php?function=get_options&data_path=/home/lephasme/takealook.dreamhosters.com/zenphoto/zp-data
    
    INFO
    
    mod_rewrite: 1
    
    INFO
    
    ZenphotoProxy call: http://www.upev.net/wp-content/plugins/zenphotopress/zenphoto_bridge.php?function=get_nested_albums&data_path=/home/lephasme/takealook.dreamhosters.com/zenphoto/zp-data
    
    INFO
    
    zenphotopress_custom_width:
    
    INFO
    
    zenphotopress_custom_height:
  6. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    It seems like you really have three duplicates of the same image in the Zenphoto database.
    It may be something in the way Zenphoto manages images when certain operations are performed. Did you edit the photo, or did you delete and the upload it again? Maybe these operations leave the Zephoto DB in a situation ZenphotoPress is not able to manage.

  7. LePhasme
    Member
    Posted 3 years ago #

    I didn't do anything with those images but you were right, they were duplicated in the database, i just deleted all the images with a title set to null and all is good now.
    Thank you for all the time you have given to my problem !

  8. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    No problem.
    Let me know in case the problem resurfaces again: it may mean it's something I've got to take into account for future versions of ZenphotoPress ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic