WordPress.org

Ready to get started?Download WordPress

Forums

ZenphotoPress
Install config problem: Wrong Zenphoto data path. (11 posts)

  1. waltzzz
    Member
    Posted 3 years ago #

    I get the message: "Wrong Zenphoto data path. It should point to the filesystem folder containing zp-config.php. Try to come up with something similar to "/home/walterl/psyberspace.walterlogeman.com/" which is your current WordPress path."

    My file system folder(where I ftp to) is /www.walterlogeman.com/photos/zenphoto/zp-data Should that have a home in front of it? I use DreamHost

    My Zenphoto Gallery URL is http://walterlogeman.com/photos/zenphoto/

    is it not working because they are on different domains?

    Happy New Year

    Walter

    http://wordpress.org/extend/plugins/zenphotopress/

  2. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    /home/username/example.com/ is the full path for DreamHost, so that part is all right, however I do believe that you will need to keep this under single domain, instead of going subdomain and domain.

  3. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, you should have a /home/walterl in front of the domain name if you're on Dreamhost.

    Have you tried with /home/walterl/www.walterlogeman.com/photos/zenphoto/zp-data ?

  4. waltzzz
    Member
    Posted 3 years ago #

    Thanks for this info. On Emil's advice I've now installed under the one domain. I have the path working.

    What happens now is that in the posts as well as in the sidebar widget I get the file name of the photo as a link. The link works and takes me to the image in Zenphoto.

    However I'd like to see the images on the blog. Am I missing something?

    http://www.psyberspace.walterlogeman.com (You can see the links in my sidebar - right at the bottom, my flickr images - the system I'm replacing - are above that)

  5. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Glad that this worked out for you.

    Images are coming from http://psyberspace.walterlogeman.com/zenphoto/albums/psyber/2011/rosenbergs.jpg to leave the images in your blog and prevent clicks you can remove the Link URL directly from the post where you inserted them. Click on photo and navigate to "Link URL" > None.

    Also I see that you or maybe this Zenphoto is using http://www.psyberspace.walterlogeman.com/zenphoto/out/2010/IMG_0924.jpg.php under "My Photos" you can freely remove www. part. In subdomains http:// is all you need :)

    Emil

  6. waltzzz
    Member
    Posted 3 years ago #

    Thanks Emil,

    No it has not quite worked out as you think. The Rosenberg image, as with all Zenphoto images on the blog were added manually, and that works ok, they don't even need to be on the same domain or path.

    When I use the plugin all I get is a link, not an image. This is true of the widget in the sidebar too, where I really have no other option to get latest images coming up.

    Id like to be able to add the images using the plugin, esp in the sidebar widget.

    Ideas?

  7. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    @waltzzz have you installed the latest Zenphoto (1.4)? It was released just a few days ago, so ZenphotoPress does not support it yet. It may be the reason why the images are not shown in your sidebar.

  8. waltzzz
    Member
    Posted 3 years ago #

    Simbul, Indeed, that must be it! I'll keep an Ernst & Young out for the update :)

    thanks.

  9. waltzzz
    Member
    Posted 3 years ago #

    oops some strange auto correct slipped into that last post:

    I'll keep an eye out for the update :)

    Walter

  10. Simbul
    Member
    Plugin Author

    Posted 3 years ago #

    I just published a hotfix: this should take care of the issue with Zenphoto 1.4.
    Just update ZenphotoPress to version 1.7.4 and let me know whether this solves your problem ;)

  11. waltzzz
    Member
    Posted 3 years ago #

    Yes, its all go!

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic