WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Assistant by Zemanta
[Plugin: Zemanta] Images not viewable in media library (18 posts)

  1. kzinke
    Member
    Posted 3 years ago #

    Images are inserting into my post fine. But my theme is not able to recognize the image and apply a thumbnail which I need for my overall layout. I have selected the "enable Zemanta image uploader" in my configuration so I thought I would manually apply the image as the featured image or thumbnail. But when I search the media library it does not see any of the images I have selected from Zemanta. Yet when I look at my "uploads" folder on my server I can see the Zemanta images there. I'm not having any problems with images I'm uploading myself (and they are all in the same server folder). How can I make the Zemanta provided images viewable in my media library?

    http://wordpress.org/extend/plugins/zemanta/

  2. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Hey!
    Unfortunately our plugin doesn't add images to the gallery, which would actually be sensible, now that I think about it. However, there's a plugin that does exactly that.
    Get it here: http://wordpress.org/extend/plugins/add-linked-images-to-gallery-v01/

    It fixes your exact problem! :)

    Let me know if it works!

    Best,
    Rok

  3. kzinke
    Member
    Posted 3 years ago #

    Hi Rok - thanks for the follow-up. I did download your suggested plug-in but unfortunately it didn't work.

    The picture file has definitely been uploaded to my uploads folder - just need WordPress to see it and add to the media library. I have another widget finding and adding an image for video files into my posts and uploads folder and both my theme and the media library can see it. Maybe there is some setting that needs to be made on my servers end to allow WP to see the files inserted by Zemanta.

    The picture ability is a must for my blog set-up and I really like the idea of Zemanta as it has saved a lot of time in my test runs. I'll definitely keep it in mind and check back to see if it's something I can use in the future.

    Thanks!
    Kim

  4. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Hey!

    We have updated the way we insert images in WordPress so it should now add them the same way WordPress does natively.
    That should fix things, so the plugin I suggested knows the image to extract. Can you try it again (but please clear your cache before you do so!).

    Thanks! Let me know!
    Rok

  5. kzinke
    Member
    Posted 3 years ago #

    I tried a brand new post tonight but it's still not working. But I also haven't seen any updates for Zemanta or the Add Linked Images plug-in - so thinking that I would need that first?

  6. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Not really. We update that on our side so you don't have to. :)
    Do you add these images as "Featured images" or not?

  7. jasonsaulnier
    Member
    Posted 3 years ago #

    I have the same problem.

  8. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Jason,
    do you insert it as a featured image? Try if that goes. I think it should work!

    Best,
    Rok

  9. kzinke
    Member
    Posted 3 years ago #

    Hi Rok - I can't add as a featured image as it's not showing up in my media library (but as I noted earlier it is showing in my uploads folder on my host site). These are the steps I'm taking.
    - click on image in Zemanta
    - image is inserted into post
    - publish post & preview - the only time I see the zemanta image is when I view the full post. No thumbnail for my first page.
    - go back to post and select "set featured image"
    - the zemanta image is not there - so nothing to select

    Am I missing a step or another way to add the image or make the featured image?

    Thanks for your patience!
    Kim

  10. rlparker81
    Member
    Posted 2 years ago #

    Hi,

    kzinke did you ever get this working as I am having the same problem?

    thanks

    Rachael

  11. kzinke
    Member
    Posted 2 years ago #

    Hi Rachael - Rok tried to help but it's still not working for me.

  12. kzinke
    Member
    Posted 2 years ago #

    Hi Rachael - I've finally had success. Activate Zemanta plug-in. Then activate the plugin named "Add Linked Images to Gallery" by Randy Hunt and in the settings I selected:
    - which external IMG links to process: all images
    - what to do with the images: replace SRC attribute with local copy

    Save changes and then hit the "process" button. All the images showed up.

    Hope that helps.
    Kim

  13. kzinke
    Member
    Posted 2 years ago #

    Hi Rachael - I've finally had success. Activate Zemanta plug-in. Then activate the plugin named "Add Linked Images to Gallery" by Randy Hunt and in the settings I selected:
    - which external IMG links to process: all images
    - what to do with the images: replace SRC attribute with local copy

    Save changes and then hit the "process" button. All the images showed up.

    Hope that helps.
    Kim

  14. rlparker81
    Member
    Posted 2 years ago #

    Hi Kim,

    Thanks for that i'll give it a try :)

    Rachael

  15. Lesliemak
    Member
    Posted 2 years ago #

    I was using Zemanta on my wp.com 24-theme site perfectly but when I upgraded to WP.com pro it went away and I don't see it listed under Tools (which I where I believe I just found it originally and set it up in my sidebar). Any suggestions? http://www.bakethiscake.com Thanks!

  16. andraz
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Lesliemak,

    WordPress.com has temporarily disabled Zemanta. In the mean time you can use browser extension that you can get at http://www.zemanta.com as a stop-gap measure.

  17. Lesliemak
    Member
    Posted 2 years ago #

    Oh wow, thank you andraz. You saved me from tons more time trying to figure out how to make it come alive again. :)

  18. andraz
    Member
    Plugin Author

    Posted 2 years ago #

    Lesliemak,
    glad to help!

    Next time you have questions about WordPress.com the right address is http://en.forums.wordpress.com/
    That way you'll get the answer faster.

    Also, we're trying to make Zemanta work on WordPress.com soon.

    bye
    andraz

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags