WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Yoast SEO ] Cannot generate sitemap.xml on multisite (2 posts)

  1. mattrad
    Member
    Posted 3 years ago #

    I'm running Yoast SEO 0.2.3.1 on a WP 3.1 multisite install, set up with subdirectories.

    (Interestingly, the plugin doesn't show up in the plugins list, but is registered in the admin sidebar. Anyway..)

    Generating a sitemap.xml works for the root site, but not for any child sites. I get an error as pasted below.

    The wpseo folder for each site is 777, and owners of the plugin and dirs are the same. Any thoughts anyone?

    Cheers
    Matt

    HANG ON: I've just tried it again and it does generate a sitemap (e.g. http://lovecakes.co.uk/sitemap.xml ), but still throws an error. I'd still like to get this sorted.

    WWarning: fopen(/home/mattradh/public_html/wp-content/blogs.dir/3/files/wpseo/sitemap.xml) [function.fopen]: failed to open stream: Permission denied in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 53
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 68
    14:06:45: Starting to generate output.
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 47
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 47
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 47
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 47
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 47
    14:06:45: 4 posts of type page found.
    14:06:45: 0 taxonomy entries of type ngg_tag found.
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 328
    14:06:45: Sitemap successfully (re-)generated with 5 URLs.
    
    Warning: fclose(): supplied argument is not a valid stream resource in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-class.php on line 333
    
    Warning: fopen(/home/mattradh/public_html/wp-content/blogs.dir/3/files/wpseo/sitemap.xml.gz) [function.fopen]: failed to open stream: Permission denied in /home/mattradh/public_html/wp-content/plugins/wordpress-seo/sitemaps/xml-sitemap-base-class.php on line 35
    14:06:46: Successfully notified of updated sitemap: Google Yahoo! Bing Ask.com 
    
    232KB of memory used.
  2. petermolnar
    Member
    Posted 2 years ago #

    Hi all,

    I'm facing the same problem here as well. I have a domain-mapped multisite with sunrise on, sitemap.xml is only available for the root site, and the server return 404 error for any other sites.

    WordPress version: 3.3.1
    WordPress SEO plugin version 1.1.5

    Please help, sitemap would be important.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags