WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Yoast Breadcrumbs] WARNING: array_slice (4 posts)

  1. palihapiz
    Member
    Posted 5 years ago #

    Im using wordpress v2.7, my breadcrumb is showing and funtion good in my blog. but in my wp dashboard showing this: -

    Warning: array_slice() expects parameter 1 to be array, null given in /home/faseven/public_html/blogging/wp-content/plugins/breadcrumbs/yoast-posts.php on line 43
    No items

    Is there any suggestion to fix it?

  2. Fill in the Blank
    Member
    Posted 5 years ago #

    I have the same issue

  3. Fill in the Blank
    Member
    Posted 5 years ago #

    I might have fixed this. Go to sociable.php and comment out the line before ?>
    change require_once("yoast-posts.php");
    to //require_once("yoast-posts.php");

    Looks like it is some rss feed checker from yoast.com. Just get rid of it.

  4. websnail
    Member
    Posted 5 years ago #

    Not sure where you're getting sociable.php from phorbidden but this fixed the issue for me:

    Open: yoast-posts.php

    Find:
    $items = array_slice($rss->items, 0, 2)

    Replace with:
    $items = is_array($rss->items) ? array_slice($rss->items, 0, 2) : '';

    That, at least stops the code erroring out..

Topic Closed

This topic has been closed to new replies.

About this Topic