WordPress.org

Ready to get started?Download WordPress

Forums

Yoast Breadcrumbs
Doesn't work with special charactres (6 posts)

  1. katenutri
    Member
    Posted 2 years ago #

    The plugin doesn't work if you put special (national) characters into the settings, e.g. "Anchor text for the Homepage:"

    I have changed the encoding of the plugin to UTF-8 - it doesn't solve the issue. Special characters get overwritten and cannot be saved.

    http://wordpress.org/extend/plugins/breadcrumbs/

  2. Mladen Gradev
    Member
    Posted 2 years ago #

    Yes, same here. Can someone help us. Its good plugin, but without special characters support its not working for me. Please, reply with solution. Thanks.

    Converting to UTF-8 is no solution.

  3. Mladen Gradev
    Member
    Posted 2 years ago #

    Katenutri,
    I find the solution.
    1. In yst_plugin_tools.php on line 165 and 203 find this function: "htmlentities" and replace it with "stripslashes".
    2. Edit Yoast Breadcrumbs plugin in wordpress admin page. Replace Home, Blog etc. with words from your native language:

    $opt['home'] = "Home(Wordinyourlanguage)";
    $opt['blog'] = "Blog(Wordinyourlanguage)";
    $opt['sep'] = "»";
    $opt['prefix'] = "You are here:(Wordinyourlang.)";
    $opt['boldlast'] = true;
    $opt['nofollowhome'] = false;
    $opt['singleparent'] = 0;
    $opt['singlecatprefix'] = true;
    $opt['archiveprefix'] = "Archives for(Wordinyourlanguage)";
    $opt['searchprefix'] = "Serches for(Wordinyourlanguage)";

    3. Go to Settings/Breadcrumbs and again replace Home, Blog etc. with words from your native language.

    In WordPress admin panel this words are still showing like this "�а�ало", but on website everything is good.

    Good luck ;)

    Original post is here, but it`s uncomplete:
    http://wordpress.org/support/topic/plugin-yoast-breadcrumbs-utf8-for-home

  4. katenutri
    Member
    Posted 2 years ago #

    Hi,

    Thanks for posting back.

    However, my problem isn't that special characters display incorrectly, but that "Special characters get overwritten and cannot be saved."

    I put in a word in Polish, save settings and when I leave the page it goes back to "Home" again. It only saves the value if I use no special characters.

    I replaced "htmlentities" with "stripslashes" but it didn't help.

    Thanks anyway.

    Kate

  5. Mladen Gradev
    Member
    Posted 2 years ago #

    Hi,
    You should make steps 2 and 3. Maybe i did not explain correctly. After step 1 you must edit yoast-breadcrumbs.php and write you special characters in the correct fields. And after that write them again in wordpress admin/Settings/Breadcrumbs. Then it somehow recognize them and everything is ok.

    Only replacing "htmlentities" with "stripslashes" is not enought. Try it again.

    Regards.

  6. katenutri
    Member
    Posted 2 years ago #

    Works indeed. It was the "edit yoast-breadcrumbs.php" that was missing in your first post.

    Well, I do think that this is a major bug in the plugin and should be fixed.

    Many thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic