WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Yet Another Related Posts Plugin] YARPP and my page number? (26 posts)

  1. zhp800204
    Member
    Posted 5 years ago #

    First,thanks for your great plugin,I have a small question,when I upgrade to the newest version,the "page break" number in my posts are gone(the "page break" is the function in wp when we write a new post),please tell me why and how to fix it.

    You can e-mail me,ross800204@gmail.com

    Thank you for your wonderful plugin again.

  2. From why version to what version did you upgrade? Are you using YARPP 3's new templating system? I assume the you're referring to the pagination page number in your theme... Can you tell me where that's defined and what code you're using?

    Also, if it's a case that no output at all is printed after the related posts, this would indicate a php error. Please check your php error log to see if there's anything from YARPP.

  3. lenea
    Member
    Posted 5 years ago #

    Dear mitchoyoshitaka,

    from me - also at first: Thanks a lot for this plugin. I have just started working with it and tuning it.

    This is also my problem:

    No pagination WITH the YARPP plugin activated. Only the first page until the page break is shown.

    When I deactivate YARPP the pages are shown perfectly.

    You say to check the php error log. Do you need that to reconstruct this error? If yes, how can I view this error log?

  4. @lenea - are you displaying the related posts on the archive/index page of your site or on the single page?

    As I said for @zhp, if there is no output at all in the source after the related posts (you can check this by viewing the source of your page in your browser) it may be a syntax error and you should check the PHP error log. The PHP error log is stored on the server and its location depends on your PHP setup. If you're on a hosting service you can normally ask the provider.

  5. onisemus
    Member
    Posted 5 years ago #

    Hi, i'm having the same problem as these other two members, however I looked and the problem isn't a PHP error. (LOVE the plugin by the way!)

    It really is as Lenea described. I installed the latest version of YARPP (latest as of 6/16/09) with WordPress version 2.8. In my posts where I have a page break (that is, where I have <!--nextpage--> ), the pagination code is not displayed when viewing the post. I have no links to the other pages in the post, so I get just the first page. YARPP itself displays just fine.

    When I deactivate YARPP the pagination on my post works just fine and the links to each page are displayed correctly. This leads me to believe there is some sort of conflict between YARPP and the way pagination works.

    The theme I'm using is a slightly customized version of the WordPress default theme. So if you were test with that version I'm pretty sure you'd see the same behavior.

    Thanks!

  6. WebG2
    Member
    Posted 5 years ago #

    I, too, am having a conflict with YARPP and the pagination nextpage feature in some of my single page posts. Using 3.0.7.

    When I disable YARPP, the pagination works correctly.

    If I keep YARPP enabled, when I MOVE the wp_link_pages function call ABOVE the_content, then the pagination works correctly (it displays above the content -- not where I would like it to be, at the bottom of the page, but at least it is displaying at the same time that YARPP is on the page). When I move the wp_link_pages function below the_content again, the pagination disappears.

    My guess is that YARPP is exiting the loop, so anything else after YARPP in the site template that must also reside in the loop is getting gonged. This is on the Single Page loop, if that matters.

    If this is truly the case, then where in the YARPP code can we place the wp_link_pages call so that the pagination occurs immediately before YARPP? My site is currently set to automatically include YARPP, so my next step would be to try adding YARPP manually instead. I would prefer not to have to do this, however, if a better option is available.

    Suggestions appreciated.

  7. ReflectionMedia
    Member
    Posted 4 years ago #

    yup! there are clearly some pagination issues for this plugin. i'm using the thematic theme.

  8. Hi all— thank you all for bringing this up. In particular, WebG2, thanks for mentioning the wp_link_pages function you're using... this helped me pin down the issue.

    I just released what I believe is a fix for this pagination issue as 3.0.8b1. If you guys could download it and give it a try, I would really appreciate it!

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.0.8b1.zip

    mitcho

  9. There was a bad bug in 3.0.8b1, so I pushed 3.0.8b2:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.0.8b2.zip

  10. DieterWelzel
    Member
    Posted 4 years ago #

    Hi,
    Great plugin and I love it.
    I have another issue.
    Use my blog in german with wp 2.8.2, yarpp 3.0.8 also as 3.0.8b2 and realized an empty option page.
    Any idea what´s the reason and maybe fix this?
    Best regards,
    Dieter

  11. @DieterWelzel are you using the DISQUS plugin by chance? There's a workaround in the FAQ:

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/faq/

  12. @reflectionmedia, @WebG2 et al... could someone confirm that pagination is working again with 3.0.8 beta 2?

    Thanks!

  13. Media un autre regard
    Member
    Posted 4 years ago #

    Hey, I had the same probleme with the pagination. I installed the new version but the problem is the same!
    I'm sad because i really like this pluggin but for the moment i can't use it.
    I hope it'll work soon
    Thanks

  14. @Media, could you tell me what template tag you're using in your template to display the pagination? Is it wp_link_pages or something else?

  15. willard97
    Member
    Posted 4 years ago #

    How can I disable YARPP for specific posts or pages? I just created a "Thank You" confirmation page for my email subscribers and I don't want to show them Related Posts on that pages is it's irrelevant.

    Can I use a custom field and false value to disable?

  16. Media un autre regard
    Member
    Posted 4 years ago #

    @mitcho I'm not a programmer so i can't answer you as precisely as you can expect. But i'm simply using WordPress 2.8.2. And to create pages i'm just typing <!--nextpage--> in my posts.
    At this moment i'm using the 3.0.8 version of your pluggin. The same problem still exists.
    Thank you

  17. @Media what theme are you using then? There must be some code in your theme which adds these links... hmm...

  18. Media un autre regard
    Member
    Posted 4 years ago #

    I use Vigilance.
    thanks

  19. DieterWelzel
    Member
    Posted 4 years ago #

    Hi,
    I´m sorry, but I didn´t and don´t use the DISQUS plugin.
    Maybe another of my nearly 50 Plugins is responsible for the issue.

    However I moved to the Related Posts by Category Plugin and everything is now fine.
    Best regards,
    Dieter

  20. @willard97 - you can do that by writing some custom code in your theme to check whether it is that special page or not and if appropriate, executing related_posts().

    @Media, I will look into this now.

  21. @Media, I believe I've resolved this issue and it will be fixed in 3.0.9.

  22. Hi all—Please try version 3.0.9.

  23. Media un autre regard
    Member
    Posted 4 years ago #

    @mitcho .. hey! Congratulations, it seems to be ok now. I'm going to test it a little more but thanks. I think you solved the problem. Good job...
    Can i suggest a next step?
    It would be great to be have the choice to make the other links appear in all the pages of an long article or just at the end of the article, at the end of the last page... as i would prefer!

    Thanks for http://www.mediaunautreregard.com (about french TV and other Media)

  24. @Media Yay! :)

  25. redsy
    Member
    Posted 4 years ago #

    Had the same issue, though after an upgrade it is fixed. Many thanks.

    The only question left is on my Property blog on this article can you see how the pages 1,2,3 is actually under the YARP structure.

    How can i get the Pages 1, 2, 3 to appear above the YARP? your help would be greatly appreciated.

    Great plugin !!!

  26. @redsy - you can move the position of the related posts display by turning off the "automatic display" option and instead inserting the code <?php related_posts(); ?> into your template code.

Topic Closed

This topic has been closed to new replies.

About this Topic