WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[Plugin: Yet Another Related Posts Plugin] upgraded to 3.2 - site is slower (18 posts)

  1. Rami Yushuvaev
    Member
    Posted 3 years ago #

    i have just upgraded from 3.1.9 to 3.0.

    when i started using YARPP few months ago, the site became slower. i installed WP-SUPER-CACHE, it didnt help much.

    today, after the upgrade to 3.2, it was so slow that i starded thinking to swich to a different plugin. for now i re-install 3.1.9.

    any suggestion to speed up the plugin?

    do you know a better plugin?

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. dadahtml
    Member
    Posted 3 years ago #

    Confirmed. With 3.2 site is very very slower.
    Trying to back to 3.1.9 but nothing resolved: site is still slower.
    I've disabled the plugin for now waiting for a fix.

    Any hint?

    WP 3.0 with this plugin

    Advanced Most Recent Posts
    HTML In Category Descriptions
    Disqus Comment System
    Facebook Social Plugins
    Google News XML Sitemap
    Google XML Sitemaps
    HTML.It Sponsored RSS
    JQuery Lazy Load Plugin
    Media Credit
    Microkid's Related Posts
    More Fields
    More Taxonomies
    More Types
    NextGEN Gallery
    Redirection
    Pulsanti TinyMCE
    Viper's Video Quicktags
    WordPress Popular Posts
    WP Nofollow Post
    WP-PageNavi
    WP Super Cache

  3. dadahtml
    Member
    Posted 3 years ago #

    I forgot to say: thank you for this awsome plugin!

  4. dadahtml
    Member
    Posted 3 years ago #

    I resolved truncating the wp_yarpp_keyword_cache and wp_yarpp_related_cache tables and installing again.

    Ciao, Francesco.

  5. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 3 years ago #

    @dadahtml thanks for the feedback. I'm glad clearing the cache resolved it.

    Rami, could you try doing that too? A new, cleaner way to do this, is to go to the YARPP settings page in your admin, add &action=flush to the URL, and reloading. Hope that helps.

  6. chadrew
    Member
    Posted 3 years ago #

    So this slowness wasn't related to the upgrade? I'm scared to update to 3.20 now :)

  7. dadahtml
    Member
    Posted 3 years ago #

    For me, 3.2 works perfectly on my blog after clearing the cache.

    Ciao, francesco.

  8. Rami Yushuvaev
    Member
    Posted 3 years ago #

    hi, i did cache clearing when i updated to 3.2.
    but if you say it's ok now, i will upgrade it again.

  9. Rami Yushuvaev
    Member
    Posted 3 years ago #

    re-installed 3.2, looked ok. the site is not slower like before.

    this time i deleted cache before upgrading the plugin and after. just in case.

  10. Rami Yushuvaev
    Member
    Posted 3 years ago #

    the second site that i run (much bigger site, 13k posts), complitly crashed after the upgrade. cant restore the site.

  11. Dave
    Member
    Posted 3 years ago #

    Am hesitant about this too. Anyone else got feedback on the upgrade?

    Current one works v well. Don't want to mess things up.

    mitcho, any other feedback?

  12. dadahtml
    Member
    Posted 3 years ago #

    I've noted that with 3.2 the site become slower as the cache tables in the YARPP DB grow in size. I've have to flush the tables every 12/15 hours.

  13. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 3 years ago #

    @dadahtml I would recommend against doing that. Clearing the cache will make the site run *slower*, not *faster*.

    Clearing the cache after upgrade to 3.2 is not a bad measure, but you should probably avoid doing this in a high-traffic peak time, as it will immediately try to reconstruct the cache. Also look at the "optimization tips" in the FAQ: this will give you ideas on making YARPP less computationally intensive.

  14. galbaras
    Member
    Posted 3 years ago #

    Mitcho, my site loads OK, but saving posts is a nightmare. I've truncates the cache tables, removed the plugin and reinstalled it and it's happening again. Clearing the minify and super cache didn't help. Resetting the plugin options didn't help either.

    I've noticed the entry in the keyword cache table for my current draft has a space for the "body" column and a space for the "title", which seems like a strange keyword to save. Is this supposed to happen?

    Publishing the post took about 2 minutes and the "body" changed to something more meaningful, but the "title" still contains a space.

    Displaying the post is quick, but subsequent saves take forever again.

    I'm disabling 3.2 and waiting for an update, my friend.

  15. Dave
    Member
    Posted 3 years ago #

    Just some feedback. Although worried, I've had no issue since the upgrade. Running as smoothly as the previous version.

  16. galbaras
    Member
    Posted 3 years ago #

    I've just realized something important: since upgrading the plugin, my server has been running out of processes.

    Mitcho, have you changed the plugin to use more processes, perhaps MySQL threads (open connections) or something?

  17. galbaras
    Member
    Posted 3 years ago #

    Anything?

  18. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 3 years ago #

    @galbaras, no such change was made (adding more processes... this is totally out of my control). As I said, clearing the cache will make things slower, not faster. Please check out the FAQ section on optimizing YARPP.

    @Dave, thanks for your feedback as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic