WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Yet Another Related Posts Plugin] Upgraded to 2,0 - now not working (43 posts)

  1. Hi all,

    I've just released version 2.0.4, what 2.0 should have been. I worked with @phorbidden and hopefully worked out a number of kinks. Please let me know if this still does not solve your issues.

    mitcho

  2. polle001
    Member
    Posted 6 years ago #

    OK, 2.0.4 works in the first instance, just upgrade anr there are related posts, not the same 10 I had before, but at least theres something.

    Something changed that having it at 2 it has 10 results and now 2 or 3 ?

    Thanks, good work.

  3. bradstinyworld
    Member
    Posted 6 years ago #

    I would suggest just skipping this plugin and using the related post feature in simple tags. It is a far more powerful plugin to start with. When used with all its features it can replace several up to half a dozen or more separate plugins.

  4. onkelandy
    Member
    Posted 6 years ago #

    True, "Simple Tags" is a brilliant plug-in. But the related posts-part isn't too clever actually. The relations sometimes really suck, so the approach of YARPP is much cooler. Hope it's gonna work ;)

  5. @polle001, the new algorithm is quite different from the 1.x algorithm and thus you may have to readjust your threshold value. Hopefully between this and being able to choose exactly which factors go into the algorithm, you'll be able to make the plugin work for you and your site.

    @bradstinyworld I agree Simple Tags is a fantastic plugin. However, its related posts algorithm is, just like the name, simply tags. Depending on how you use tags on your site (or not use tags) actually looking at the content and title will give better results. Yes, my plugin is more complicated in this regard, and this contributed to the horrible bug fest of the past two days, but I do feel the final results are better. @onkelandy, thanks for the defense. :)

    mitcho

  6. iliand
    Member
    Posted 6 years ago #

    2.0.4 now works fine. Thanks for the quick response :)

  7. onkelandy
    Member
    Posted 6 years ago #

    Hi! v2.0.4 is working like a charm, cool and thanks for the work! I'm just using it for some hours now and already have a wish ;) Right now you have the option that the related posts have to share at least one tag or more than one tag in common (besides just (not) consider). Wouldn't it be possible to change the option to PERCENTAGE. I was just checking out some posts on my blog and realized that some post only have i.e. 1 or 2 tags.

    So when "more than one tag" is turned on, the plugin won't find any related posts at all, although there are some! So an additional cool option would be something like "more than 25%/50%/75% percent", maybe just "more than half" would also be fine. Although this option should work like "at least one" on posts with less than three tags in it.. Something like that ;) Maybe you get a clue what I'm talking about *g*

  8. terasuccubi
    Member
    Posted 6 years ago #

    Updated to WordPress 2.6 and 2.0.4 and it's wonderful!

    *huggles*

    Thank you for all your efforts!

    TeraS

  9. wzeallor
    Member
    Posted 6 years ago #

    This works but I had to change line two of:

    if (function_exists('related_posts_exist')) {
    	if (related_posts_exist()) {
    		echo '<div class="related"><strong>Related Posts:</strong><ul>';
    		related_posts();
    		echo'</ul></div>';
    	}
    }

    to

    if (related_posts()) {

    which I think is odd because I thought that related_posts_exist was meant for how I used it.

  10. @iliand @onkelandy @terasuccubi Yay! I'm so glad things are working so well for you guys. ^^

    @onkelandy, Hm, that's actually not a bad idea... I may incorporate the more than 50% condition in a future version, though I'm afraid of adding too many options and buttons to the options page! If some other users could weigh in, I'd appreciate that.

    mitcho

  11. @wzeallor, were you having issues with related_posts_exist()? So was another user, and I now know why. I just made that bugfix in the dev version , in case you'd like to go back to using related_posts_exist().

    @wzeallor, do you mind trying this new version with your original code? I'm curious if that fixes the issue.

    mitcho

  12. wzeallor
    Member
    Posted 6 years ago #

    Nah doesn't work for me still. Looking through your plugin's superb settings, I've found that it's completely unnecessary anyway. I'm using

    if (function_exists('related_posts')) {
    	related_posts();
    }

    I've set the "display if no results" to empty and the before and after to what was echoed.

    Thanks for your work!

  13. IainPurdie
    Member
    Posted 6 years ago #

    Mitch,

    I auto-upgraded to 2.0.4 and everything now seems to work perfectly. Thanks so much for all the work and effort! Sorry I didn't reply sooner, but I'm backpacking through Cambodia and internet access hasn't been as frequent as I'd hoped :)

    Iain (http://www.moshtour.me.uk)

Topic Closed

This topic has been closed to new replies.

About this Topic