WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[Plugin: Yet Another Related Posts Plugin] Related posts not showing for new post (10 posts)

  1. azn137
    Member
    Posted 2 years ago #

    So I upgraded to YARPP v3.5.1 a few days ago. Ever since, my new posts come up with "No related post".

    It's worth noting that I have W3TC.

    The workaround is to either modify the threshold to force the plugin to flush the cache, or install the "experiment" plugin to flush it manually (not sure why this feature doesn't come with the official plugin). Once the cache has been built (it really takes a few tries, as it tends to stop prematurely), I have to clear the cache of W3TC to make the related posts appear on the aforementioned new post.

    Is there a fix for all this?

    Thanks.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    So, as I understand your description, you are now getting related posts displayed? So this was just a one-time hiccup after upgrading? Or am I misunderstanding?

  3. azn137
    Member
    Posted 2 years ago #

    No, related posts do not show for new posts, ever. I have to manually flush the cache every time I post a new entry. So I guess they do show, but not automatically.

  4. azn137
    Member
    Posted 2 years ago #

    I'll set relatedness to '1' to make sure they all show something. It's a workaround for now. Thanks.

  5. TheSupercargo
    Member
    Posted 2 years ago #

    I also have this problem.

    A new post, which is Part 2 of a series & has exactly the same tags and catgoris as Part 1: YARP 3.5.1 returns 'No related posts'.

    Am also running the latest WP 3.3.1

  6. azn137
    Member
    Posted 2 years ago #

    Nope, setting relatedness to '1' doesn't do the trick for new posts. I keep on having to flush the YARPP cache and then rebuild it :(

  7. Jabawack
    Member
    Posted 2 years ago #

    *edit*
    Wrong post

  8. azn137
    Member
    Posted 2 years ago #

    Anybody having the same problem like I do?

  9. vectyr
    Member
    Posted 2 years ago #

    I'm having the exact same problem. Just installed the plugin and am getting no related posts. I think it's a bug. If there's a solution I'd love to hear it, this looks like a great plugin otherwise.

  10. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    Please try this latest beta: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.2b2.zip It fixes an issue which was recently introduced in 3.5.1 or so which affects some users. I'd appreciate your feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic