WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[Plugin: Yet Another Related Posts Plugin] No related posts (9 posts)

  1. renai42
    Member
    Posted 2 years ago #

    hi guys,

    like a few other people I upgraded to a new version of YARPP a month or so back and now every article shows "No related posts".

    I have tried adding "&action=flush" to the end of my YARPP settings page and also upgrading to the latest beta of the plugin, but no luck so far.

    Is there a standardised way of handling this issue? As it stands, the plugin's functionality has simply disappeared overnight, which is a pity, as I've been using it for two years now without a problem, and I don't want to switch to another plugin.

    Cheers,

    Renai
    Editor/Publisher, Delimiter.com.au

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. narfonix
    Member
    Posted 2 years ago #

    Same issue here. I am working on rolling back to previous versions to see if that resolves the problem. All of my old posts still have related posts but any new posts since the upgrade to not have any related posts. I also tried the newest version as well as the Beta that displays.

  3. narfonix
    Member
    Posted 2 years ago #

    Ahh so I take that back regarding the BETA. It appears that a couple of the .js files located in wp-content/plugins/yet-another-related-posts-plugin/js/ folder were owned by root and not deleting properly on my server combined with the fact that if you actually update the posts that don't have any related posts the related posts will get generated at that time.

    I will be keeping an eye on it but appears to be working as expected at this point for me. I appreciate the time spent creating and updating the plugin.

  4. narfonix
    Member
    Posted 2 years ago #

    I take this back... The issues started again no matter if I roll back one version from the beta or two versions from the beta... no dice on related posts. Does anyone have suggestions on another related posts plugin to use?

  5. narfonix
    Member
    Posted 2 years ago #

    Ohh wow... I am a doofus! I was wondering where all the settings went. If anyone else is having this same issue click Screen Options when on the YARPP Settings page and make sure each of the check boxes is checked. This will provide you with all of the settings and more than likely if your related posts are not displaying you don't consider enough items (title, body, tags, etc.) and your Match Threshold is to high... the lower the more matches.

    Sorry for all the posts and for my ignorance. :) All is working perfecto now. I am guessing when I upgraded/downgraded numerous times that my settings got lost in the mix.

  6. azn137
    Member
    Posted 2 years ago #

    i've been having this issue ever since 3.4.x

    I just removed the plugin, dropped its tables on myphpadmin sql db (apparently removing the plugin doesn't remove its tables), then reinstalled it. we'll see how this goes.

  7. renai42
    Member
    Posted 2 years ago #

    hey Narfonix, this fixed the issue for me -- for some reason all the 'relatedness' settings had been set to 'do not consider'. I set them back to 'consider' and all of a sudden related posts started showing up on my site :)

    Cheers!

    Renai

  8. boatgalley
    Member
    Posted 2 years ago #

    @narfonix --

    THANK YOU, THANK YOU, THANK YOU for telling me where to find my missing settings!!

    Carolyn

  9. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 2 years ago #

    Please try this latest beta: http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.5.2b2.zip It fixes an issue which was recently introduced in 3.5.1 or so which affects some users. I'd appreciate your feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic